summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-code-coverage6.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-code-coverage6.spec')
-rw-r--r--php-phpunit-php-code-coverage6.spec17
1 files changed, 12 insertions, 5 deletions
diff --git a/php-phpunit-php-code-coverage6.spec b/php-phpunit-php-code-coverage6.spec
index b4a3b9f..ce31869 100644
--- a/php-phpunit-php-code-coverage6.spec
+++ b/php-phpunit-php-code-coverage6.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-php-code-coverage6
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -24,7 +24,6 @@
%global ver_major 6
%global ver_minor 1
%global ver_patch 4
-%global specrel 1
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
@@ -33,7 +32,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
Version: %{ver_major}.%{ver_minor}.%{ver_patch}
-Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}.%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Release: 2%{?dist}
Summary: PHP code coverage information
# Main license is BSD
@@ -71,7 +70,7 @@ BuildRequires: php-theseer-tokenizer >= 1.1
# "phpunit/phpunit": "^7.0"
# 7.2 because of tests
BuildRequires: phpunit7 >= 7.2
-BuildRequires: php-pecl-xdebug >= 2.6.0
+BuildRequires: php-xdebug >= 2.6.0
%endif
# From composer.json, require
@@ -182,12 +181,17 @@ require __DIR__ . '/TestCase.php';
define('TEST_FILES_PATH', __DIR__ . '/_files/');
EOF
+# Related to xdebug v3
+FILTER="testCloverForFileWithIgnoredLines|testCloverForClassWithAnonymousFunction|testGetLinesToBeIgnored3\
+|testGetLinesToBeIgnoredOneLineAnnotations|testForFileWithIgnoredLines|testForClassWithAnonymousFunction"
+
ret=0
-for cmd in php php71 php72 php73; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd $EXT \
-d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php \
%{_bindir}/phpunit7 \
+ --filter "^((?!($FILTER)).)*$" \
--verbose || ret=1
fi
done
@@ -206,6 +210,9 @@ exit $ret
%changelog
+* Wed Mar 24 2021 Remi Collet <remi@remirepo.net> - 6.1.4-2
+- skip tests failing with xdebug v3
+
* Wed Oct 31 2018 Remi Collet <remi@remirepo.net> - 6.1.4-1
- update to 6.1.4