summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json15
-rw-r--r--php-phpunit-php-code-coverage5.spec12
2 files changed, 16 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 23b7a12..ed87651 100644
--- a/composer.json
+++ b/composer.json
@@ -12,14 +12,18 @@
"authors": [
{
"name": "Sebastian Bergmann",
- "email": "sb@sebastian-bergmann.de",
+ "email": "sebastian@phpunit.de",
"role": "lead"
}
],
"support": {
- "issues": "https://github.com/sebastianbergmann/php-code-coverage/issues",
- "irc": "irc://irc.freenode.net/phpunit"
+ "issues": "https://github.com/sebastianbergmann/php-code-coverage/issues"
},
+ "config": {
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
+ "prefer-stable": true,
"require": {
"php": "^7.0",
"ext-dom": "*",
@@ -33,8 +37,7 @@
"theseer/tokenizer": "^1.1"
},
"require-dev": {
- "phpunit/phpunit": "^6.0",
- "ext-xdebug": "^2.5"
+ "phpunit/phpunit": "^6.0"
},
"suggest": {
"ext-xdebug": "^2.5.5"
@@ -46,7 +49,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "5.2.x-dev"
+ "dev-master": "5.3.x-dev"
}
}
}
diff --git a/php-phpunit-php-code-coverage5.spec b/php-phpunit-php-code-coverage5.spec
index b873b1a..6b01829 100644
--- a/php-phpunit-php-code-coverage5.spec
+++ b/php-phpunit-php-code-coverage5.spec
@@ -9,7 +9,7 @@
%global bootstrap 0
# Github
-%global gh_commit 033ec97498cf530cc1be4199264cad568b19be26
+%global gh_commit 661f34d0bd3f1a7225ef491a70a020ad23a057a1
#global gh_date 20150924
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -22,8 +22,8 @@
%global ns_project CodeCoverage
%global php_home %{_datadir}/php
%global ver_major 5
-%global ver_minor 2
-%global ver_patch 4
+%global ver_minor 3
+%global ver_patch 0
%global specrel 1
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -67,8 +67,7 @@ BuildRequires: php-composer(sebastian/version) >= 2.0.1
BuildRequires: php-composer(theseer/tokenizer) < 2
BuildRequires: php-composer(theseer/tokenizer) >= 1.1
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^6.0",
-# "ext-xdebug": "^2.5.5"
+# "phpunit/phpunit": "^6.0"
BuildRequires: phpunit6
BuildRequires: php-pecl-xdebug >= 2.5.5
%endif
@@ -212,6 +211,9 @@ exit $ret
%changelog
+* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 5.3.0-1
+- Update to 5.3.0
+
* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 5.2.4-1
- Update to 5.2.4
- raise dependency on phpunit/php-token-stream 2.0.1