summaryrefslogtreecommitdiffstats
path: root/php-phpunit-mock-objects6.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-mock-objects6.spec')
-rw-r--r--php-phpunit-mock-objects6.spec12
1 files changed, 7 insertions, 5 deletions
diff --git a/php-phpunit-mock-objects6.spec b/php-phpunit-mock-objects6.spec
index c9836d8..ab6da32 100644
--- a/php-phpunit-mock-objects6.spec
+++ b/php-phpunit-mock-objects6.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# Github
-%global gh_commit 70c740bde8fd9ea9ea295be1cd875dd7b267e157
+%global gh_commit f9756fd4f43f014cb2dca98deeaaa8ce5500a36e
#global gh_date 20150902
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -23,7 +23,7 @@
%global php_home %{_datadir}/php
%global ver_major 6
%global ver_minor 1
-%global ver_patch 1
+%global ver_patch 2
%global specrel 1
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -48,7 +48,7 @@ BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
BuildRequires: php(language) >= 7.1
# remirepo:1
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
BuildRequires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
BuildRequires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
@@ -70,7 +70,7 @@ BuildRequires: phpunit7
# "sebastian/exporter": "^3.1"
Requires: php(language) >= 7.1
# remirepo:1
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
Requires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
Requires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
@@ -143,7 +143,6 @@ for cmd in php php71 php72; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
%{_bindir}/phpunit7 \
- --filter '^((?!(testVerificationOfMethodNameFailsWithWrongParameters)).)*$' \
--no-coverage || ret=1
fi
done
@@ -163,6 +162,9 @@ exit $ret
%changelog
+* Wed May 30 2018 Remi Collet <remi@remirepo.net> - 6.1.2-1
+- update to 6.1.2
+
* Wed Apr 11 2018 Remi Collet <remi@remirepo.net> - 6.1.1-1
- update to 6.1.1