summaryrefslogtreecommitdiffstats
path: root/php-phpunit-mock-objects5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-mock-objects5.spec')
-rw-r--r--php-phpunit-mock-objects5.spec11
1 files changed, 8 insertions, 3 deletions
diff --git a/php-phpunit-mock-objects5.spec b/php-phpunit-mock-objects5.spec
index b552bdc..af6bb0f 100644
--- a/php-phpunit-mock-objects5.spec
+++ b/php-phpunit-mock-objects5.spec
@@ -24,7 +24,7 @@
%global ver_major 5
%global ver_minor 0
%global ver_patch 10
-%global specrel 2
+%global specrel 3
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
@@ -42,6 +42,8 @@ Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commi
# Temporary workaround, under investigation
Patch0: %{name}-rpm.patch
+# For 7.4
+Patch1: %{name}-php74.patch
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
@@ -106,6 +108,7 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_top}/%{ns_project}%{ver_major}/autoloa
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0
+%patch1 -p1
find . -name \*.orig -exec rm {} \; -print
@@ -144,7 +147,7 @@ EOF
rm tests/Generator/return_type_declarations_final.phpt
ret=0
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
%{_bindir}/phpunit6 \
@@ -166,8 +169,10 @@ exit $ret
%{php_home}/%{ns_vendor}/%{ns_top}/%{ns_project}%{ver_major}/
-## TODO drop the filter with phpunit 6.5.11
%changelog
+* Wed Aug 21 2019 Remi Collet <remi@remirepo.net> - 3.4.4-5
+- fix deprecated usage of ReflectionType::__toString()
+
* Tue Feb 5 2019 Remi Collet <remi@remirepo.net> - 5.0.10-2
- fix FTBFS ignoring test failing with recent PHP versions