summaryrefslogtreecommitdiffstats
path: root/php-phpunit-mock-objects5.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-07 18:08:24 +0100
committerRemi Collet <remi@remirepo.net>2018-01-07 18:08:24 +0100
commit3b32adca4a3b210da3eda23d4d004bfdefbd47b6 (patch)
tree2767eb6ab8a9de46ab174d5594fb8215b42bf18a /php-phpunit-mock-objects5.spec
parent13e5a4117c400e107b5a8749ca7efa475dff834b (diff)
v5.0.6 (broken)
Diffstat (limited to 'php-phpunit-mock-objects5.spec')
-rw-r--r--php-phpunit-mock-objects5.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/php-phpunit-mock-objects5.spec b/php-phpunit-mock-objects5.spec
index e9ae0e6..2b4e0e3 100644
--- a/php-phpunit-mock-objects5.spec
+++ b/php-phpunit-mock-objects5.spec
@@ -6,9 +6,9 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 1
+%global bootstrap 0
# Github
-%global gh_commit 283b9f4f670e3a6fd6c4ff95c51a952eb5c75933
+%global gh_commit 33fd41a76e746b8fa96d00b49a23dadfa8334cdf
#global gh_date 20150902
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -23,8 +23,8 @@
%global php_home %{_datadir}/php
%global ver_major 5
%global ver_minor 0
-%global ver_patch 5
-%global specrel 0
+%global ver_patch 6
+%global specrel 1
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
@@ -138,7 +138,7 @@ ret=0
for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
- %{_bindir}/phpunit6 --no-coverage --verbose
+ %{_bindir}/phpunit6 --no-coverage || ret=1
fi
done
exit $ret
@@ -156,6 +156,11 @@ exit $ret
%changelog
+* Sun Jan 7 2018 Remi Collet <remi@remirepo.net> - 5.0.6-1
+- Update to 5.0.6
+- open issue for test failure with PHP 7.0
+ https://github.com/sebastianbergmann/phpunit-mock-objects/issues/398
+
* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 5.0.5-1
- Update to 5.0.5
- raise dependency on sebastian/exporter 3.1