summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-13 07:17:10 +0200
committerRemi Collet <remi@remirepo.net>2018-07-13 07:17:10 +0200
commit0339095df7202f2a1fef293fc1a9ddc9a9219a4d (patch)
tree2c88fba11b99b4c5b61550d51ca0e165b365cd8b
parent9eaece889b05ba64b3bcfdcf6fefef77bc6443a9 (diff)
v5.0.8
-rw-r--r--php-phpunit-mock-objects5.spec14
1 files changed, 8 insertions, 6 deletions
diff --git a/php-phpunit-mock-objects5.spec b/php-phpunit-mock-objects5.spec
index 45f968f..6763598 100644
--- a/php-phpunit-mock-objects5.spec
+++ b/php-phpunit-mock-objects5.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# Github
-%global gh_commit 3eaf040f20154d27d6da59ca2c6e28ac8fd56dce
+%global gh_commit 6f9a3c8bf34188a2b53ce2ae7a126089c53e0a9f
#global gh_date 20150902
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -23,7 +23,7 @@
%global php_home %{_datadir}/php
%global ver_major 5
%global ver_minor 0
-%global ver_patch 7
+%global ver_patch 8
%global specrel 1
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -52,7 +52,7 @@ BuildRequires: php(language) >= 7.0
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
BuildRequires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
-BuildRequires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
+BuildRequires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
# remirepo:5
%else
BuildRequires: php-phpunit-Text-Template >= 1.2.1
@@ -74,7 +74,7 @@ Requires: php(language) >= 7.0
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
Requires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
-Requires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
+Requires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
# remirepo:5
%else
Requires: php-phpunit-Text-Template >= 1.2.1
@@ -145,11 +145,10 @@ EOF
rm tests/Generator/return_type_declarations_final.phpt
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
%{_bindir}/phpunit6 \
- --filter '^((?!(testVerificationOfMethodNameFailsWithWrongParameters)).)*$' \
--no-coverage || ret=1
fi
done
@@ -168,6 +167,9 @@ exit $ret
%changelog
+* Fri Jul 13 2018 Remi Collet <remi@remirepo.net> - 5.0.8-1
+- update to 5.0.8
+
* Wed May 30 2018 Remi Collet <remi@remirepo.net> - 5.0.7-1
- update to 5.0.7