summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-10-20 08:09:51 +0200
committerRemi Collet <fedora@famillecollet.com>2013-10-20 08:09:51 +0200
commitebfd7b87f0c8e59c2e71c25c148b72f5eca12f78 (patch)
treeac42d8b79e6478bff49a78a7c341cf4ae704868a
php-phpunit-diff: rename
-rw-r--r--Makefile4
-rw-r--r--php-phpunit-diff.spec103
2 files changed, 107 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-phpunit-diff.spec b/php-phpunit-diff.spec
new file mode 100644
index 0000000..8de4632
--- /dev/null
+++ b/php-phpunit-diff.spec
@@ -0,0 +1,103 @@
+# spec file for php-phpunit-diff
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Diff
+%global pear_channel pear.phpunit.de
+
+Name: php-phpunit-diff
+Version: 1.1.0
+Release: 2%{?dist}
+Summary: Diff implementation
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/sebastianbergmann/diff
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.3
+BuildRequires: php-pear(PEAR) >= 1.9.4
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+# from package.xml
+Requires: php(language) >= 5.3.3
+Requires: php-pear(PEAR) >= 1.9.4
+Requires: php-channel(%{pear_channel})
+# from phpcompatinfo report for version 1.1.0
+Requires: php-pcre
+Requires: php-spl
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+# Package have be renamed
+Obsoletes: php-phpunit-Diff < 1.1.0-2
+Provides: php-phpunit-Diff = %{name}-%{version}
+
+%description
+Diff implementation.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%dir %{pear_phpdir}/SebastianBergmann
+%{pear_phpdir}/SebastianBergmann/%{pear_name}
+
+
+
+%changelog
+* Sun Oct 20 2013 Remi Collet <remi@fedoraproject.org> - 1.1.0-2
+- rename to lowercase
+
+* Thu Sep 12 2013 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- initial package