summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-12 10:51:16 +0200
committerRemi Collet <remi@remirepo.net>2017-08-12 10:51:16 +0200
commitcf7dcd2b80aa04c3c3194483818ea0a77b406dd3 (patch)
tree8789930327a3711ce5e9f57aaf824030aed56958
parent43db55c92fba65ad2757e42d4e0e1c70db7393bd (diff)
don't use phpunit6 which requires diff v2, FTBFS from Koschei
-rw-r--r--php-phpunit-diff.spec17
1 files changed, 8 insertions, 9 deletions
diff --git a/php-phpunit-diff.spec b/php-phpunit-diff.spec
index 7828f3b..e794ee6 100644
--- a/php-phpunit-diff.spec
+++ b/php-phpunit-diff.spec
@@ -22,7 +22,7 @@
Name: php-phpunit-diff
Version: 1.4.3
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Diff implementation
Group: Development/Libraries
@@ -38,11 +38,7 @@ BuildRequires: php-fedora-autoloader-devel
# "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0"
# min version ignored
BuildRequires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
%global phpunit %{_bindir}/phpunit
-%endif
BuildRequires: %{phpunit}
%endif
@@ -86,11 +82,11 @@ cp -pr src %{buildroot}%{php_home}/SebastianBergmann/Diff
%if %{with_tests}
%check
ret=0
-for cmd in "php %{phpunit}" %{?rhel:php54 php55} php56 php70 "php71 %{_bindir}/phpunit6" "php72 %{_bindir}/phpunit6"; do
- set $cmd
+for cmd in php %{?rhel:php54 php55} php56 php70 php71 php72; do
if which $cmd; then
- $1 -d include_path=.:%{buildroot}%{php_home}:%{php_home}:%{_datadir}/pear \
- ${2:-%{_bindir}/phpunit} \
+ $cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home}:%{_datadir}/pear \
+ -d auto_prepend_file=%{buildroot}%{php_home}/SebastianBergmann/Diff/autoload.php \
+ %{phpunit} \
--bootstrap %{buildroot}%{php_home}/SebastianBergmann/Diff/autoload.php \
--verbose || ret=1
fi
@@ -116,6 +112,9 @@ fi
%changelog
+* Sat Aug 12 2017 Remi Collet <remi@remirepo.net> - 1.4.3-3
+- don't use phpunit6 which requires diff v2, FTBFS from Koschei
+
* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 1.4.3-1
- Update to 1.4.3