summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-04-03 13:59:25 +0200
committerRemi Collet <fedora@famillecollet.com>2015-04-03 13:59:25 +0200
commit1c7b4338ab481e244b6836133ab66244dd968009 (patch)
tree8474a44e895097396478540713601c47b2f770f6
parentb7d7be8a4f9422b5e76977a711542f4ae957cc1b (diff)
php-phpunit-diff: 1.3.0
-rw-r--r--php-phpunit-diff.spec36
1 files changed, 22 insertions, 14 deletions
diff --git a/php-phpunit-diff.spec b/php-phpunit-diff.spec
index 619e558..d3f37f8 100644
--- a/php-phpunit-diff.spec
+++ b/php-phpunit-diff.spec
@@ -7,11 +7,11 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5843509fed39dee4b356a306401e9dd1a931fec7
+%global gh_commit 863df9687835c62aa423a22412d26fa2ebde3fd3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project diff
-%global php_home %{_datadir}/php/SebastianBergmann
+%global php_home %{_datadir}/php
%global pear_name Diff
%global pear_channel pear.phpunit.de
%if %{bootstrap}
@@ -21,7 +21,7 @@
%endif
Name: php-phpunit-diff
-Version: 1.2.0
+Version: 1.3.0
Release: 1%{?dist}
Summary: Diff implementation
@@ -35,7 +35,9 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.3.3
BuildRequires: %{_bindir}/phpab
%if %{with_tests}
-BuildRequires: php-phpunit-PHPUnit >= 4.2
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "~4.2"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.2
%endif
# from composer.json
@@ -60,24 +62,27 @@ Diff implementation.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+# Restore PSR-0 tree
+mkdir SebastianBergmann
+mv src SebastianBergmann/Diff
+
%build
phpab \
- --output src/autoload.php \
- src
+ --output SebastianBergmann/Diff/autoload.php \
+ SebastianBergmann/Diff
%install
-rm -rf %{buildroot}
-mkdir -p %{buildroot}%{php_home}
-cp -pr src %{buildroot}%{php_home}/%{pear_name}
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}/SebastianBergmann
+cp -pr SebastianBergmann/Diff \
+ %{buildroot}%{php_home}/SebastianBergmann/Diff
%if %{with_tests}
%check
-phpunit \
- --bootstrap src/autoload.php \
- -d date.timezone=UTC
+phpunit --bootstrap SebastianBergmann/Diff/autoload.php
%endif
@@ -97,11 +102,14 @@ fi
%license LICENSE
%doc README.md composer.json
-%dir %{php_home}
-%{php_home}/%{pear_name}
+%dir %{php_home}/SebastianBergmann
+ %{php_home}/SebastianBergmann/Diff
%changelog
+* Fri Apr 3 2015 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
+- update to 1.3.0
+
* Fri Oct 3 2014 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
- update to 1.2.0
- run test suite during build