summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-07 17:14:46 +0100
committerRemi Collet <remi@remirepo.net>2018-02-07 17:14:46 +0100
commitb6f42fa5475347c3f8b166e967d8da52d3e39e63 (patch)
treed5d04f9f6aa3c115da2bee21a07ba090e1334752
parent6b1a10d8edb6b73aba1000f6b3950ca2539c5c25 (diff)
update to 4.0.0
switch dependency from phpunit6 to phpunit7 rename to php-phpunit-dbunit4 move to /usr/share/php/PHPUnit7/DbUnit raise dependency on PHP 7.1
-rw-r--r--composer.json6
-rw-r--r--php-phpunit-dbunit4.spec51
2 files changed, 28 insertions, 29 deletions
diff --git a/composer.json b/composer.json
index 2588fb9..44dce20 100644
--- a/composer.json
+++ b/composer.json
@@ -20,8 +20,8 @@
"issues": "https://github.com/sebastianbergmann/dbunit/issues"
},
"require": {
- "php": "^7.0",
- "phpunit/phpunit": "^6.0",
+ "php": "^7.1",
+ "phpunit/phpunit": "^7.0",
"symfony/yaml": "^3.0 || ^4.0",
"ext-pdo": "*",
"ext-simplexml": "*"
@@ -33,7 +33,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "3.0.x-dev"
+ "dev-master": "4.0-dev"
}
}
}
diff --git a/php-phpunit-dbunit4.spec b/php-phpunit-dbunit4.spec
index 5b5a59c..977cf25 100644
--- a/php-phpunit-dbunit4.spec
+++ b/php-phpunit-dbunit4.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for php-phpunit-dbunit3
+# remirepo/fedora spec file for php-phpunit-dbunit4
#
# Copyright (c) 2010-2018 Remi Collet
# License: CC-BY-SA
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 0fa4329e490480ab957fe7b1185ea0996ca11f44
+%global gh_commit e77b469c3962b5a563f09a2a989f1c9bd38b8615
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project dbunit
@@ -15,20 +15,19 @@
%global pk_vendor phpunit
%global pk_project dbunit
# Namespace
-%global ns_vendor PHPUnit6
+%global ns_vendor PHPUnit7
%global ns_project DbUnit
%global with_tests 0%{!?_without_tests:1}
-%global ver_major 3
+%global ver_major 4
%global ver_minor 0
-%global ver_patch 3
+%global ver_patch 0
%global specrel 1
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
Version: %{ver_major}.%{ver_minor}.%{ver_patch}
Release: %{specrel}%{?dist}
-Summary: PHPUnit extension for database interaction testing
+Summary: Extension for database interaction testing for PHPUnit %{ver_major}
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
@@ -36,31 +35,31 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.1
BuildRequires: php-pdo
BuildRequires: php-simplexml
-BuildRequires: phpunit6
+BuildRequires: phpunit7
%if 0%{?fedora} >= 27
BuildRequires: (php-composer(symfony/yaml) >= 3.0 with php-composer(symfony/yaml) < 5)
%else
-BuildRequires: php-composer(symfony/yaml) < 4
+BuildRequires: php-symfony4-yaml
%endif
%endif
# From composer.json
-# "php": "^7.0",
-# "phpunit/phpunit": "^6.0",
+# "php": "^7.1",
+# "phpunit/phpunit": "^7.0",
# "symfony/yaml": "^3.0 || ^4.0",
# "ext-pdo": "*",
# "ext-simplexml": "*"
-Requires: php(language) >= 7.0
+Requires: php(language) >= 7.1
Requires: php-pdo
Requires: php-simplexml
-Requires: phpunit6
+Requires: phpunit7
%if 0%{?fedora} >= 27
Requires: (php-composer(symfony/yaml) >= 3.0 with php-composer(symfony/yaml) < 5)
%else
-Requires: php-composer(symfony/yaml) < 4
+Requires: php-symfony4-yaml
%endif
# From phpcompatinfo report for version 3.0.0
Requires: php-reflection
@@ -69,16 +68,9 @@ Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
-%if 0%{?fedora} > 99
-Obsoletes: php-phpunit-Dbunit < %{ver_major}
-Provides: php-phpunit-Dbunit = %{version}
-Provides: %{pk_project} = %{version}
-Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
-%endif
-
%description
-PHPUnit extension for database interaction testing.
+Extension for database interaction testing for PHPUnit %{ver_major}.
Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
@@ -97,7 +89,7 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
cat << 'EOF' | tee -a src/autoload.php
// Dependencies
-foreach(['Symfony4', 'Symfony3', 'Symfony'] as $sym) {
+foreach(['Symfony4', 'Symfony3'] as $sym) {
if (is_dir("/usr/share/php/$sym/Component/Yaml")) {
\Fedora\Autoloader\Autoload::addPsr4('Symfony\\Component\\Yaml', "/usr/share/php/$sym/Component/Yaml");
break;
@@ -119,10 +111,10 @@ touch vendor/autoload.php
: Run tests
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php71 php72; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php \
- %{_bindir}/phpunit6 --verbose || ret=1
+ %{_bindir}/phpunit7 --verbose || ret=1
fi
done
exit $ret
@@ -138,6 +130,13 @@ exit $ret
%changelog
+* Wed Feb 7 2018 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- update to 4.0.0
+- switch dependency from phpunit6 to phpunit7
+- rename to php-phpunit-dbunit4
+- move to /usr/share/php/PHPUnit7/DbUnit
+- raise dependency on PHP 7.1
+
* Tue Jan 23 2018 Remi Collet <remi@remirepo.net> - 3.0.3-1
- Update to 3.0.3
- use range dependencies on F27+