summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phpunit-comparator.spec11
1 files changed, 7 insertions, 4 deletions
diff --git a/php-phpunit-comparator.spec b/php-phpunit-comparator.spec
index 98a2b51..b1d266c 100644
--- a/php-phpunit-comparator.spec
+++ b/php-phpunit-comparator.spec
@@ -22,7 +22,7 @@
Name: php-phpunit-comparator
Version: 1.2.4
-Release: 4%{?dist}
+Release: 6%{?dist}
Summary: Compare PHP values for equality
Group: Development/Libraries
@@ -44,7 +44,7 @@ BuildRequires: php-composer(phpunit/phpunit) >= 4.4
# "sebastian/diff": "~1.2",
# "sebastian/exporter": "~1.2 || ~2.0"
Requires: php(language) >= 5.3.3
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(sebastian/diff) >= 1.2 with php-composer(sebastian/diff) < 2)
Requires: (php-composer(sebastian/exporter) >= 1.2 with php-composer(sebastian/exporter) < 3)
%else
@@ -96,8 +96,8 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
sed -e '/vendor/d' -i tests/bootstrap.php
sed -e '/log/d' phpunit.xml.dist >phpunit.xml
-run=0
-for cmd in php php56 php70 php71 php72; do
+ret=0
+for cmd in php php56 php70 php71 php72 php73; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
%{_bindir}/phpunit --verbose || ret=1
@@ -118,6 +118,9 @@ exit $ret
%changelog
+* Tue Dec 4 2018 Remi Collet <remi@fedoraproject.org> - 1.2.4-6
+- cleanup for EL-8
+
* Tue Feb 6 2018 Remi Collet <remi@fedoraproject.org> - 1.2.4-4
- use range dependencies on F27+