summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-18 11:53:50 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-18 11:53:50 +0200
commite0a329f68df38e1fed47390ca6f8f233c93d7590 (patch)
tree8eee917baac6d5ae3588baf9f71759190db9fc62
parent79fc33d3b0b884ba34e5d4a4c518c69ee42ff1c8 (diff)
php-phpunit-Version: 2.0.0
-rw-r--r--composer-dev.json29
-rw-r--r--composer.json21
-rw-r--r--php-phpunit-Version-dev.spec14
3 files changed, 60 insertions, 4 deletions
diff --git a/composer-dev.json b/composer-dev.json
new file mode 100644
index 0000000..3b87814
--- /dev/null
+++ b/composer-dev.json
@@ -0,0 +1,29 @@
+{
+ "name": "sebastian/version",
+ "description": "Library that helps with managing the version number of Git-hosted PHP projects",
+ "homepage": "https://github.com/sebastianbergmann/version",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/version/issues"
+ },
+ "require": {
+ "php": ">=5.6"
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.0.x-dev"
+ }
+ }
+}
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..39d6569
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,21 @@
+{
+ "name": "sebastian/version",
+ "description": "Library that helps with managing the version number of Git-hosted PHP projects",
+ "homepage": "https://github.com/sebastianbergmann/version",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/version/issues"
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ }
+}
diff --git a/php-phpunit-Version-dev.spec b/php-phpunit-Version-dev.spec
index 6c4af01..e937064 100644
--- a/php-phpunit-Version-dev.spec
+++ b/php-phpunit-Version-dev.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 58b3a85e7999757d6ad81c787a1fbf5ff6c628c6
+%global gh_commit c829badbd8fdf16a0bad8aa7fa7971c029f1b9c5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project version
@@ -14,7 +14,7 @@
%global with_tests %{?_without_tests:0}%{!?_withou_tests:1}
Name: php-phpunit-Version
-Version: 1.0.6
+Version: 2.0.0
Release: 1%{?dist}
Summary: Managing the version number of Git-hosted PHP projects
@@ -25,10 +25,12 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-BuildRequires: php(language) >= 5.3.3
+BuildRequires: php(language) >= 5.6
BuildRequires: %{_bindir}/phpab
-Requires: php(language) >= 5.3.3
+# From composer.json, "require": {
+# "php": ">=5.6"
+Requires: php(language) >= 5.6
Requires: php-spl
Requires: git
@@ -84,6 +86,10 @@ fi
%changelog
+* Mon Apr 18 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0
+- raise minimal php version to 5.6
+
* Sun Jun 21 2015 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
- Update to 1.0.6
- generate autoloader