summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-30 19:14:55 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-30 19:14:55 +0100
commit180a0f56e5a6f72b65cda3b6247cb6a3d6d5879b (patch)
tree9b2b40ca6bc616e94bf58fb25b34584c0f433ef8
php-phpunit-Text-Template: import from rawhide
-rw-r--r--php-phpunit-Text-Template.spec118
1 files changed, 118 insertions, 0 deletions
diff --git a/php-phpunit-Text-Template.spec b/php-phpunit-Text-Template.spec
new file mode 100644
index 0000000..731cb1e
--- /dev/null
+++ b/php-phpunit-Text-Template.spec
@@ -0,0 +1,118 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Text_Template
+%global channel pear.phpunit.de
+
+Name: php-phpunit-Text-Template
+Version: 1.1.4
+Release: 3%{?dist}
+Summary: Simple template engine
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/sebastianbergmann/php-text-template
+Source0: http://pear.phpunit.de/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.9.4
+BuildRequires: php-channel(%{channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-channel(%{channel})
+Requires: php-common >= 5.3.3
+Requires: php-spl
+
+Provides: php-pear(%{channel}/%{pear_name}) = %{version}
+
+%description
+Simple template engine.
+
+
+%prep
+%setup -q -c
+cd %{pear_name}-%{version}
+# package.xml is V2
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+install -Dpm 644 %{name}.xml %{buildroot}%{pear_xmldir}/%{name}.xml
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Text
+
+
+%changelog
+* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+
+* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Thu Nov 1 2012 Remi Collet <remi@fedoraproject.org> - 1.1.4-1
+- Version 1.1.4 (stable) - API 1.1.0 (stable)
+
+* Sat Oct 6 2012 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
+- Version 1.1.3 (stable) - API 1.1.0 (stable)
+
+* Mon Sep 24 2012 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
+- Version 1.1.2 (stable) - API 1.1.0 (stable)
+- LICENSE is now provided in upstream tarball
+
+* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Tue Nov 01 2011 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- Version 1.1.1 (stable) - API 1.1.0 (stable)
+- raise dependencies, PEAR 1.9.4 and PHP 5.2.7
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Sun Dec 05 2010 Remi Collet <Fedora@famillecollet.com> - 1.1.0-1
+- Version 1.1.0 (stable) - API 1.1.0 (stable)
+- remove README.mardown (which is only install doc)
+
+* Fri Nov 05 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-2
+- fix URL
+
+* Sun Sep 26 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-1
+- initial generated spec + clean
+