summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-21 19:28:13 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-21 19:28:13 +0200
commit131220af8a5e00d9f25ae6ebe4dff0ff941db466 (patch)
tree57c445048b7076abbdc9568382e2db9b276c68b6
parentf609d3600cea4b1a9b20c9b58dde90d68ae3b727 (diff)
php-phpunit-Text-Template: 1.2.1
-rw-r--r--php-phpunit-Text-Template.spec37
1 files changed, 22 insertions, 15 deletions
diff --git a/php-phpunit-Text-Template.spec b/php-phpunit-Text-Template.spec
index 4a6dad3..2c87ac7 100644
--- a/php-phpunit-Text-Template.spec
+++ b/php-phpunit-Text-Template.spec
@@ -6,29 +6,28 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 206dfefc0ffe9cebf65c413e3d0e809c82fbf00a
+%global gh_commit 31f8b717e51d9a2afca6c9f046f5d69fc27c8686
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-text-template
%global php_home %{_datadir}/php
%global pear_name Text_Template
%global pear_channel pear.phpunit.de
-# Circular dependency with phpunit
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: php-phpunit-Text-Template
-Version: 1.2.0
-Release: 5%{?dist}
+Version: 1.2.1
+Release: 1%{?dist}
Summary: Simple template engine
Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.3
+BuildRequires: %{_bindir}/phpab
# From composer.json
Requires: php(language) >= 5.3.3
@@ -45,17 +44,18 @@ Simple template engine.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-rm Text/Template/Autoload.php.in
+: Restore previous PSR-0 layout
+mkdir -p Text/Template
+mv src/Template.php Text/
+rmdir src
%build
-# Empty build section, most likely nothing required.
-
-# If upstream drop Autoload.php, command to generate it
-#phpab \
-# --output Text/Template/Autoload.php \
-# --template Text/Template/Autoload.php.in \
-# Text
+: Generate autoloader
+%{_bindir}/phpab \
+ --output Text/Template/Autoload.php \
+ --basedir Text/Template \
+ Text
%install
@@ -77,11 +77,18 @@ fi
%files
%defattr(-,root,root,-)
-%doc ChangeLog.md README.md LICENSE composer.json
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md
+%doc composer.json
%{php_home}/*
%changelog
+* Sun Jun 21 2015 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
+- update to 1.2.1
+- generate autoloader
+
* Sat Jun 7 2014 Remi Collet <remi@fedoraproject.org> - 1.2.0-4
- composer dependencies