summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHPUnit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-PHPUnit.spec')
-rw-r--r--php-phpunit-PHPUnit.spec304
1 files changed, 304 insertions, 0 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
new file mode 100644
index 0000000..7f0edb7
--- /dev/null
+++ b/php-phpunit-PHPUnit.spec
@@ -0,0 +1,304 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name PHPUnit
+%global channel pear.phpunit.de
+
+Name: php-phpunit-PHPUnit
+Version: 3.6.12
+Release: 1%{?dist}
+Summary: The PHP Unit Testing framework
+
+Group: Development/Libraries
+License: BSD
+URL: http://www.phpunit.de
+Source0: http://pear.phpunit.de/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.9.4
+BuildRequires: php-channel(%{channel})
+
+Requires: php-xml >= 5.2.7
+Requires: php-channel(%{channel})
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(%{channel}/File_Iterator) >= 1.3.0
+Requires: php-pear(%{channel}/Text_Template) >= 1.1.1
+Requires: php-pear(%{channel}/PHP_CodeCoverage) >= 1.1.0
+Requires: php-pear(%{channel}/PHP_Timer) >= 1.0.1
+Requires: php-pear(pear.symfony-project.com/YAML) >= 1.0.2
+# PHPUnit Extensions (yes, with circular dependency on PHPUnit)
+Requires: php-pear(%{channel}/PHPUnit_MockObject) >= 1.1.0
+
+# Optionnal dependencies
+Requires: php-json php-pdo php-mbstring
+Requires: php-pecl(Xdebug) >= 2.0.5
+Requires: php-pear(%{channel}/PHP_Invoker) >= 1.1.0
+
+Provides: php-pear(%{channel}/%{pear_name}) = %{version}
+Obsoletes: php-pear-PHPUnit < %{version}
+Provides: php-pear-PHPUnit = %{version}-%{release}
+
+
+%description
+PHPUnit is a family of PEAR packages that supports the development of
+object-oriented PHP applications using the concepts and methods of Agile
+Software Development, Extreme Programming, Test-Driven Development and
+Design-by-Contract Development by providing an elegant and robust framework
+for the creation, execution and analysis of Unit Tests.
+
+
+%prep
+%setup -qc
+cd %{pear_name}-%{version}
+# package.xml is V2
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+
+# Install Package
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_phpdir}/.??*
+
+# Install XML package description
+install -d %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{channel}/%{pear_name} >/dev/null || :
+fi
+
+%triggerpostun -- php-pear-PHPUnit
+# re-register extension unregistered during postun of obsoleted php-pear-PHPUnit
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/%{pear_name}
+%{_bindir}/phpunit
+
+
+%changelog
+* Sat Aug 04 2012 Remi Collet <remi@fedoraproject.org> - 3.6.12-1
+- Version 3.6.12 (stable) - API 3.6.0 (stable)
+
+* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.11-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Thu Jun 07 2012 Remi Collet <remi@fedoraproject.org> - 3.6.11-1
+- Version 3.6.11 (stable) - API 3.6.0 (stable)
+
+* Fri Jan 27 2012 Remi Collet <remi@fedoraproject.org> - 3.6.10-1
+- Version 3.6.10 (stable) - API 3.6.0 (stable)
+- raise PHP_Invokers >= 1.1.0
+
+* Tue Jan 24 2012 Remi Collet <remi@fedoraproject.org> - 3.6.9-1
+- Version 3.6.9 (stable) - API 3.6.0 (stable)
+
+* Sat Jan 21 2012 Remi Collet <remi@fedoraproject.org> - 3.6.8-1
+- Version 3.6.8 (stable) - API 3.6.0 (stable)
+
+* Thu Jan 05 2012 Remi Collet <remi@fedoraproject.org> - 3.6.7-1
+- Version 3.6.7 (stable) - API 3.6.0 (stable)
+
+* Mon Jan 02 2012 Remi Collet <remi@fedoraproject.org> - 3.6.6-1
+- Version 3.6.6 (stable) - API 3.6.0 (stable)
+
+* Mon Dec 19 2011 Remi Collet <remi@fedoraproject.org> - 3.6.5-1
+- Version 3.6.5 (stable) - API 3.6.0 (stable)
+
+* Sat Nov 26 2011 Remi Collet <remi@fedoraproject.org> - 3.6.4-1
+- Version 3.6.4 (stable) - API 3.6.0 (stable)
+
+* Fri Nov 11 2011 Remi Collet <remi@fedoraproject.org> - 3.6.3-1
+- Version 3.6.3 (stable) - API 3.6.0 (stable)
+
+* Fri Nov 04 2011 Remi Collet <remi@fedoraproject.org> - 3.6.2-1
+- Version 3.6.2 (stable) - API 3.6.0 (stable)
+
+* Tue Nov 01 2011 Remi Collet <remi@fedoraproject.org> - 3.6.0-1
+- Version 3.6.0 (stable) - API 3.6.0 (stable)
+
+* Fri Aug 19 2011 Remi Collet <remi@fedoraproject.org> - 3.5.15-1
+- Version 3.5.15 (stable) - API 3.5.7 (stable)
+- raise PEAR dependency to 1.9.3
+
+* Fri Jun 10 2011 Remi Collet <Fedora@famillecollet.com> - 3.5.14-1
+- Version 3.5.14 (stable) - API 3.5.7 (stable)
+
+* Tue May 3 2011 Remi Collet <Fedora@famillecollet.com> - 3.5.13-2
+- rebuild for doc in /usr/share/doc/pear
+
+* Tue Mar 8 2011 Remi Collet <Fedora@famillecollet.com> - 3.5.13-1
+- Version 3.5.13 (stable) - API 3.5.7 (stable)
+- remove PEAR hack (only needed for EPEL)
+- raise PEAR dependency to 1.9.2
+- remove duplicate dependency (YAML)
+
+* Thu Feb 24 2011 Remi Collet <Fedora@famillecollet.com> - 3.5.12-1
+- Version 3.5.12 (stable) - API 3.5.7 (stable)
+
+* Wed Feb 16 2011 Remi Collet <Fedora@famillecollet.com> - 3.5.11-1
+- Version 3.5.11 (stable) - API 3.5.7 (stable)
+- new dependency on php-pear(XML_RPC2)
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.10-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Thu Jan 20 2011 Remi Collet <Fedora@famillecollet.com> - 3.5.10-1
+- Version 3.5.10 (stable) - API 3.5.7 (stable)
+
+* Tue Jan 18 2011 Remi Collet <Fedora@famillecollet.com> - 3.5.9-1
+- Version 3.5.9 (stable) - API 3.5.7 (stable)
+
+* Tue Jan 11 2011 Remi Collet <Fedora@famillecollet.com> - 3.5.7-1
+- Version 3.5.7 (stable) - API 3.5.7 (stable)
+- README, CHANGELOG and LICENSE are now in the tarball
+
+* Mon Dec 20 2010 Remi Collet <Fedora@famillecollet.com> - 3.5.6-1
+- Version 3.5.6 (stable) - API 3.5.4 (stable)
+- move README.mardown to README (was Changelog, now links to doc)
+- add CHANGELOG
+- not more doc provided by upstream
+
+* Mon Nov 22 2010 Remi Collet <Fedora@famillecollet.com> - 3.5.5-1
+- Version 3.5.5 (stable) - API 3.5.4 (stable)
+
+* Wed Nov 17 2010 Remi Collet <Fedora@famillecollet.com> - 3.5.4-1
+- Version 3.5.4 (stable) - API 3.5.4 (stable)
+
+* Wed Oct 27 2010 Remi Collet <Fedora@famillecollet.com> - 3.5.3-1
+- Update to 3.5.3
+- new requires and new packages for extensions of PHPUnit
+ PHPUnit_MockObject, PHPUnit_Selenium, DbUnit
+- lower PEAR dependency to allow el6 build
+- define timezone during build
+
+* Thu Jul 22 2010 Remi Collet <Fedora@famillecollet.com> - 3.4.15-1
+- Update to 3.4.15
+
+* Sat Jun 19 2010 Remi Collet <Fedora@famillecollet.com> - 3.4.14-1
+- Update to 3.4.14
+
+* Sat May 22 2010 Remi Collet <Fedora@famillecollet.com> - 3.4.13-1
+- Update to 3.4.13
+- add README.markdown (Changelog)
+
+* Wed Apr 07 2010 Remi Collet <Fedora@famillecollet.com> - 3.4.12-1
+- Update to 3.4.12
+
+* Thu Feb 18 2010 Remi Collet <Fedora@famillecollet.com> - 3.4.11-1.1
+- Update to 3.4.11
+
+* Wed Feb 10 2010 Remi Collet <Fedora@famillecollet.com> - 3.4.10-1
+- Update to 3.4.10
+
+* Sun Jan 24 2010 Remi Collet <Fedora@famillecollet.com> - 3.4.9-1
+- Update to 3.4.9
+
+* Sat Jan 16 2010 Remi Collet <Fedora@famillecollet.com> - 3.4.7-1
+- Update to 3.4.7
+- rename from php-pear-PHPUnit to php-phpunit-PHPUnit
+- update dependencies (PEAR 1.8.1, YAML, php-soap)
+
+* Sat Sep 12 2009 Christopher Stone <chris.stone@gmail.com> 3.3.17-1
+- Upstream sync
+
+* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.16-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Sat May 02 2009 Remi Collet <Fedora@famillecollet.com> - 3.3.16-1
+- Upstream sync
+- Fix requires (remove hint) and raise PEAR version to 1.7.1
+- rename %%{pear_name}.xml to %%{name}.xml
+
+* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.4-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Sat Nov 8 2008 Christopher Stone <chris.stone@gmail.com> 3.3.4-1
+- Upstream sync
+
+* Thu Oct 23 2008 Christopher Stone <chris.stone@gmail.com> 3.3.2-1
+- Upstream sync
+- Remove no longer needed Obsolete/Provides
+
+* Thu Oct 09 2008 Christopher Stone <chris.stone@gmail.com> 3.3.1-1
+- Upstream sync
+
+* Thu Oct 09 2008 Christopher Stone <chris.stone@gmail.com> 3.2.21-1
+- Upstream sync
+- Add php-xml to Requires (bz #464758)
+
+* Thu May 22 2008 Christopher Stone <chris.stone@gmail.com> 3.2.19-1
+- Upstream sync
+
+* Thu Feb 21 2008 Christopher Stone <chris.stone@gmail.com> 3.2.15-1
+- Upstream sync
+
+* Wed Feb 13 2008 Christopher Stone <chris.stone@gmail.com> 3.2.13-1
+- Upstream sync
+
+* Sun Nov 25 2007 Christopher Stone <chris.stone@gmail.com> 3.2.1-1
+- Upstream sync
+
+* Sat Sep 08 2007 Christopher Stone <chris.stone@gmail.com> 3.1.8-1
+- Upstream sync
+
+* Sun May 06 2007 Christopher Stone <chris.stone@gmail.com> 3.0.6-1
+- Upstream sync
+
+* Thu Mar 08 2007 Christopher Stone <chris.stone@gmail.com> 3.0.5-3
+- Fix testdir
+- Fix Provides version
+
+* Wed Mar 07 2007 Christopher Stone <chris.stone@gmail.com> 3.0.5-2
+- Add Obsoletes/Provides for php-pear(PHPUnit2)
+- Requires php-pear(PEAR) >= 1.5.0
+- Own %%{pear_testdir}/%%{pear_name}
+- Remove no longer needed manual channel install
+- Simplify %%doc
+- Only unregister old phpunit on upgrade
+
+* Mon Feb 26 2007 Christopher Stone <chris.stone@gmail.com> 3.0.5-1
+- Upstream sync
+
+* Wed Feb 21 2007 Christohper Stone <chris.stone@gmail.com> 3.0.4-1
+- Upstream sync
+
+* Mon Jan 29 2007 Christopher Stone <chris.stone@gmail.com> 3.0.3-1
+- Upstream sync
+
+* Sun Jan 14 2007 Christopher Stone <chris.stone@gmail.com> 3.0.2-1
+- Upstream sync
+
+* Fri Jan 05 2007 Christopher Stone <chris.stone@gmail.com> 3.0.1-1
+- Upstream sync
+
+* Wed Dec 27 2006 Christopher Stone <chris.stone@gmail.com> 3.0.0-1
+- Initial Release