summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPUnit-msg.patch20
-rw-r--r--php-phpunit-PHPUnit.spec14
2 files changed, 32 insertions, 2 deletions
diff --git a/PHPUnit-msg.patch b/PHPUnit-msg.patch
new file mode 100644
index 0000000..af319ae
--- /dev/null
+++ b/PHPUnit-msg.patch
@@ -0,0 +1,20 @@
+diff -up PHPUnit-3.7.35/PHPUnit/TextUI/TestRunner.php.old PHPUnit-3.7.35/PHPUnit/TextUI/TestRunner.php
+--- PHPUnit-3.7.35/PHPUnit/TextUI/TestRunner.php.old 2014-04-22 17:24:35.000000000 +0200
++++ PHPUnit-3.7.35/PHPUnit/TextUI/TestRunner.php 2014-04-22 17:25:46.000000000 +0200
+@@ -488,16 +488,6 @@ class PHPUnit_TextUI_TestRunner extends
+ if (!self::$versionStringPrinted) {
+ self::write(PHPUnit_Runner_Version::getVersionString() . "\n\n");
+
+- if (strpos('3.7.35', '@version') !== 0) {
+- self::write(
+- "You have installed PHPUnit via PEAR. This installation method is no longer\n" .
+- "supported and http://pear.phpunit.de/ will be shut down no later than\n" .
+- "December, 31 2014.\n\n" .
+- "Please read http://phpunit.de/manual/current/en/installation.html and\n" .
+- "learn how to use PHPUnit from a PHAR or install it via Composer.\n\n"
+- );
+- }
+-
+ self::$versionStringPrinted = TRUE;
+ }
+ }
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 42908c6..53cf6a2 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -14,7 +14,7 @@
Name: php-phpunit-PHPUnit
Version: 3.7.35
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: The PHP Unit Testing framework
Group: Development/Libraries
@@ -22,6 +22,9 @@ License: BSD
URL: http://www.phpunit.de
Source0: http://pear.phpunit.de/get/%{pear_name}-%{version}.tgz
+# Don't display message about deprecated PEAR
+Patch0: %{pear_name}-msg.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.3
@@ -74,9 +77,13 @@ for the creation, execution and analysis of Unit Tests.
%prep
%setup -qc
+
cd %{pear_name}-%{version}
+%patch0 -p1 -b .msg
+
# package.xml is V2
-mv ../package.xml %{name}.xml
+sed -e '/TestRunner.php/s/md5sum="[^"]*"//' \
+ ../package.xml >%{name}.xml
%build
@@ -129,6 +136,9 @@ fi
%changelog
+* Tue Apr 22 2014 Remi Collet <remi@fedoraproject.org> - 3.7.35-2
+- remove message about deprecated PEAR channel
+
* Tue Apr 22 2014 Remi Collet <remi@fedoraproject.org> - 3.7.35-1
- Update to 3.7.35