summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phpunit-PHPUnit.spec7
-rw-r--r--phpunit-rpm.patch10
2 files changed, 11 insertions, 6 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index db914f3..e609d45 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -18,7 +18,7 @@
Name: php-phpunit-PHPUnit
Version: 4.1.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: The PHP Unit Testing framework
Group: Development/Libraries
@@ -86,6 +86,8 @@ Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
# Package have been rename
Obsoletes: php-pear-PHPUnit < %{version}
Provides: php-pear-PHPUnit = %{version}-%{release}
+# Project
+Provides: phpunit = %{version}-%{release}
%description
@@ -152,6 +154,9 @@ fi
%changelog
+* Tue May 6 2014 Remi Collet <remi@fedoraproject.org> - 4.1.0-2
+- fix some autoload issues
+
* Sat May 3 2014 Remi Collet <remi@fedoraproject.org> - 4.1.0-1
- Update to 4.1.0
diff --git a/phpunit-rpm.patch b/phpunit-rpm.patch
index 0a1253b..34f65ba 100644
--- a/phpunit-rpm.patch
+++ b/phpunit-rpm.patch
@@ -1,13 +1,13 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2014-04-29 16:21:26.000000000 +0200
-+++ ./phpunit 2014-04-29 16:22:50.000000000 +0200
+--- ./phpunit.rpm 2014-05-02 09:13:40.000000000 +0200
++++ ./phpunit 2014-05-06 15:37:05.557950817 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env php
+#!/usr/bin/php
<?php
/* PHPUnit
*
-@@ -35,21 +35,6 @@
+@@ -35,21 +35,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
@@ -26,7 +26,7 @@ diff -up ./phpunit.rpm ./phpunit
- );
-}
-
--require PHPUNIT_COMPOSER_INSTALL;
-+require 'PHPUnit/Autoload.php';
++define ('PHPUNIT_COMPOSER_INSTALL', stream_resolve_include_path('PHPUnit/Autoload.php'));
+ require PHPUNIT_COMPOSER_INSTALL;
PHPUnit_TextUI_Command::main();