summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHPUnit.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-19 13:57:28 +0100
committerRemi Collet <remi@remirepo.net>2021-03-19 13:57:28 +0100
commita63c25848535f0154f37d9c7483bde9f57c94499 (patch)
treef663c7b8805ddfdba5d8add73ce5a0aaeed21423 /php-phpunit-PHPUnit.spec
parent89cb694604a131c9aec70b3746912fe381c5dfe2 (diff)
add minimal fix for PHP 8
Diffstat (limited to 'php-phpunit-PHPUnit.spec')
-rw-r--r--php-phpunit-PHPUnit.spec23
1 files changed, 13 insertions, 10 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 7648657..0e28da6 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-PHPUnit
#
-# Copyright (c) 2010-2018 Remi Collet
+# Copyright (c) 2010-2021 Remi Collet
# Copyright (c) 2006-2009 Christopher Stone
#
# License: MIT
@@ -25,23 +25,20 @@
Name: php-phpunit-PHPUnit
Version: %{major}.%{minor}
-Release: 6%{?dist}
+Release: 11%{?dist}
Summary: The PHP Unit Testing framework version 5
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-%if 1
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-%else
-Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
-Source1: makesrc.sh
-%endif
# Autoload template, from version 3.7
Source2: %{gh_project}-5.4.0-Autoload.php.in
# Fix command for autoload
Patch0: %{gh_project}-rpm.patch
+# Minimal fix for PHP 8
+Patch1: %{gh_project}-php8.patch
BuildArch: noarch
BuildRequires: php(language) >= 5.6
@@ -208,10 +205,13 @@ Documentation: https://phpunit.readthedocs.io/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p0 -b .rpm
-
+%patch0 -p1 -b .rpm
# Restore PSR-0 tree
mv src PHPUnit
+%patch1 -p1 -b .php8
+
+find . \( -name \*.rpm -o -name \*.php8 \) -delete -print
+
%build
@@ -238,7 +238,7 @@ install -D -p -m 755 phpunit %{buildroot}%{_bindir}/phpunit
OPT="--testsuite=small --no-coverage"
ret=0
-for cmd in php70 php71 php; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd ./phpunit $OPT --verbose
fi
@@ -263,6 +263,9 @@ fi
%changelog
+* Fri Mar 19 2021 Remi Collet <remi@remirepo.net> - 5.7.27-11
+- add minimal fix for PHP 8
+
* Mon Mar 18 2019 Remi Collet <remi@remirepo.net> - 5.7.27-6
- improve package description