summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHPUnit.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-02 17:05:48 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-02 17:05:48 +0100
commit274ad5676867d556600412b882b62499c429b8d5 (patch)
treecab6cf68b2a04c083c8301921f07119a498b48f2 /php-phpunit-PHPUnit.spec
parentf3b3e514cab12127cfa95b510272000299c8f3a9 (diff)
php-phpunit-PHPUnit: sync with rawhide
Diffstat (limited to 'php-phpunit-PHPUnit.spec')
-rw-r--r--php-phpunit-PHPUnit.spec49
1 files changed, 31 insertions, 18 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 4a270aa..3071443 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -1,10 +1,10 @@
%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name PHPUnit
-%global channel pear.phpunit.de
+%global pear_name PHPUnit
+%global pear_channel pear.phpunit.de
Name: php-phpunit-PHPUnit
-Version: 3.7.8
+Version: 3.7.9
Release: 1%{?dist}
Summary: The PHP Unit Testing framework
@@ -17,28 +17,38 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.9.4
-BuildRequires: php-channel(%{channel})
-
-Requires: php-xml >= 5.3.3
-Requires: php-channel(%{channel})
+BuildRequires: php-channel(%{pear_channel})
+
+Requires: php(language) >= 5.3.3
+Requires: php-ctype
+Requires: php-dom
+Requires: php-libxml
+Requires: php-pcntl
+Requires: php-pcre
+Requires: php-reflection
+Requires: php-spl
+Requires: php-tidy
+Requires: php-channel(%{pear_channel})
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(%{channel}/File_Iterator) >= 1.3.0
-Requires: php-pear(%{channel}/Text_Template) >= 1.1.1
-Requires: php-pear(%{channel}/PHP_CodeCoverage) >= 1.2.1
-Conflicts: php-pear(%{channel}/PHP_CodeCoverage) > 1.2.99
-Requires: php-pear(%{channel}/PHP_Timer) >= 1.0.2
+Requires: php-pear(%{pear_channel}/File_Iterator) >= 1.3.0
+Requires: php-pear(%{pear_channel}/Text_Template) >= 1.1.1
+Requires: php-pear(%{pear_channel}/PHP_CodeCoverage) >= 1.2.1
+Conflicts: php-pear(%{pear_channel}/PHP_CodeCoverage) > 1.2.99
+Requires: php-pear(%{pear_channel}/PHP_Timer) >= 1.0.2
Requires: php-pear(pear.symfony.com/Yaml) >= 2.1.0
# PHPUnit Extensions (yes, with circular dependency on PHPUnit)
-Requires: php-pear(%{channel}/PHPUnit_MockObject) >= 1.2.0
-Conflicts: php-pear(%{channel}/PHPUnit_MockObject) > 1.2.99
+Requires: php-pear(%{pear_channel}/PHPUnit_MockObject) >= 1.2.0
+Conflicts: php-pear(%{pear_channel}/PHPUnit_MockObject) > 1.2.99
# Optionnal dependencies
-Requires: php-json php-pdo php-mbstring
+Requires: php-json
+Requires: php-pdo
+Requires: php-mbstring
Requires: php-pecl(Xdebug) >= 2.0.5
-Requires: php-pear(%{channel}/PHP_Invoker) >= 1.1.0
+Requires: php-pear(%{pear_channel}/PHP_Invoker) >= 1.1.0
-Provides: php-pear(%{channel}/%{pear_name}) = %{version}
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
Obsoletes: php-pear-PHPUnit < %{version}
Provides: php-pear-PHPUnit = %{version}-%{release}
@@ -89,7 +99,7 @@ rm -rf %{buildroot}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- %{channel}/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
%triggerpostun -- php-pear-PHPUnit
@@ -108,6 +118,9 @@ fi
%changelog
+* Wed Nov 07 2012 Remi Collet <remi@fedoraproject.org> - 3.7.9-1
+- Version 3.7.9 (stable) - API 3.7.0 (stable)
+
* Thu Oct 18 2012 Remi Collet <remi@fedoraproject.org> - 3.7.8-1
- Version 3.7.8 (stable) - API 3.7.0 (stable)