summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-25 15:54:34 +0100
committerRemi Collet <remi@remirepo.net>2021-03-25 15:54:34 +0100
commitcba9992be7a788dcd37f2c5841cb8975c7afd525 (patch)
treec9ff44c01b6c3aacf73c2c18f3ed198bccbcf925
parent3cba6202f888c85281babda43a2bef55dedbf5c6 (diff)
switch to Symfony 4
-rw-r--r--php-phpunit-PHPUnit.spec9
-rw-r--r--phpunit-5.4.0-Autoload.php.in2
2 files changed, 7 insertions, 4 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 9c55984..4825ddd 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -25,7 +25,7 @@
Name: php-phpunit-PHPUnit
Version: %{major}.%{minor}
-Release: 12%{?dist}
+Release: 13%{?dist}
Summary: The PHP Unit Testing framework version 5
License: BSD
@@ -84,7 +84,7 @@ BuildRequires: php-phpunit-PHP-Invoker >= 1.1
BuildRequires: php-doctrine-instantiator >= 1.0.4
BuildRequires: php-sebastian-recursion-context
%endif
-BuildRequires: php-symfony-yaml
+BuildRequires: php-symfony4-yaml
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -151,7 +151,7 @@ Requires: php-sebastian-resource-operations
Requires: php-phpunit-Version >= 2.0.1
Requires: php-myclabs-deep-copy >= 1.3
%endif
-Requires: php-symfony-yaml
+Requires: php-symfony4-yaml
Requires: php-dom
Requires: php-json
Requires: php-mbstring
@@ -270,6 +270,9 @@ fi
%changelog
+* Thu Mar 25 2021 Remi Collet <remi@remirepo.net> - 5.7.27-13
+- switch to Symfony 4
+
* Thu Mar 25 2021 Remi Collet <remi@remirepo.net> - 5.7.27-12
- recommend using a supported version
diff --git a/phpunit-5.4.0-Autoload.php.in b/phpunit-5.4.0-Autoload.php.in
index 00d7cb0..e8b4c4d 100644
--- a/phpunit-5.4.0-Autoload.php.in
+++ b/phpunit-5.4.0-Autoload.php.in
@@ -12,7 +12,7 @@ if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
__DIR__
);
-$sym = (getenv('RPM_SYMFONY_TREE') ?: 'Symfony');
+$sym = (getenv('RPM_SYMFONY_TREE') ?: 'Symfony4');
/* don't use symfony autoloader which pull some unwanted stuff (polyfill) */
$vendorDir = stream_resolve_include_path("$sym/Component/Yaml/Yaml.php");
\Fedora\Autoloader\Autoload::addPsr4('Symfony\\Component\\Yaml\\', dirname($vendorDir));