summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-11 19:19:37 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-11 19:19:37 +0100
commitcad8f2d90227efe9fb1b2906aba66fc75e4727aa (patch)
tree11293fabc980bac035b206cca2244eac7ebb8e58
parentca3efbdde60612b72ad6f9404114633922a0878b (diff)
php-phpunit-PHPUnit: 4.3.5
-rw-r--r--php-phpunit-PHPUnit.spec11
-rw-r--r--phpunit-rpm.patch6
2 files changed, 11 insertions, 6 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 53df2ef..ede1daf 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 23e4e0310f037aae873cc81b8658dbbb82878f71
+%global gh_commit 2dab9d593997db4abcf58d0daf798eb4e9cecfe1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -17,7 +17,7 @@
%global pear_channel pear.phpunit.de
Name: php-phpunit-PHPUnit
-Version: 4.3.4
+Version: 4.3.5
Release: 1%{?dist}
Summary: The PHP Unit Testing framework
@@ -178,8 +178,7 @@ sed -e 's:PHPUnit/Autoload:src/Autoload:' \
./phpunit \
--include-path=%{buildroot}%{php_home} \
- --testsuite=small \
- -d date.timezone=UTC
+ --testsuite=small
%clean
@@ -204,6 +203,10 @@ fi
%changelog
+* Tue Nov 11 2014 Remi Collet <remi@fedoraproject.org> - 4.3.5-1
+- Update to 4.3.5
+- define date.timezone in phpunit command to avoid warning
+
* Sat Oct 25 2014 Remi Collet <remi@fedoraproject.org> - 4.3.4-1
- Update to 4.3.4
- raise dependency on phpunit/php-file-iterator >= 1.3.2
diff --git a/phpunit-rpm.patch b/phpunit-rpm.patch
index 4c5dbea..a0ec349 100644
--- a/phpunit-rpm.patch
+++ b/phpunit-rpm.patch
@@ -7,7 +7,7 @@ diff -up ./phpunit.rpm ./phpunit
<?php
/* PHPUnit
*
-@@ -35,22 +35,7 @@
+@@ -35,22 +35,10 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
@@ -16,7 +16,9 @@ diff -up ./phpunit.rpm ./phpunit
- define('PHPUNIT_COMPOSER_INSTALL', $file);
- break;
- }
--}
++if (!ini_get('date.timezone')) {
++ ini_set('date.timezone', 'UTC');
+ }
-
-unset($file);
-