summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-04-07 14:58:59 +0200
committerRemi Collet <fedora@famillecollet.com>2015-04-07 14:58:59 +0200
commitaa9bc536d15ab58b09b97c3c547db07b03b0f37a (patch)
tree06ed06f064358eb836b896e98d89added780e487
parenta97e220d99ca4919cf553163d0627e7159dd0014 (diff)
php-phpunit-PHPUnit: 4.6.2
-rw-r--r--Autoload.php.in1
-rw-r--r--php-phpunit-PHPUnit.spec7
-rw-r--r--phpunit-rpm.patch3
3 files changed, 7 insertions, 4 deletions
diff --git a/Autoload.php.in b/Autoload.php.in
index 8247632..f12fd6e 100644
--- a/Autoload.php.in
+++ b/Autoload.php.in
@@ -16,7 +16,6 @@ require_once 'SebastianBergmann/Comparator/autoload.php';
require_once 'SebastianBergmann/GlobalState/autoload.php';
require_once 'Doctrine/Instantiator/autoload.php';
require_once 'Prophecy/autoload.php';
-require_once 'PHPUnit/Framework/Assert/Functions.php';
$vendorDir = '/usr/share/php';
require_once $vendorDir . '/Symfony/Component/ClassLoader/UniversalClassLoader.php';
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index aa4c278..9a97971 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 08b2aacdd8433abbba468f995d6d64b76a7a62ec
+%global gh_commit 6c773fda0bdb5ea891d9e4430dcc26c990b9130b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -17,7 +17,7 @@
%global pear_channel pear.phpunit.de
Name: php-phpunit-PHPUnit
-Version: 4.6.1
+Version: 4.6.2
Release: 1%{?dist}
Summary: The PHP Unit Testing framework
@@ -205,6 +205,9 @@ fi
%changelog
+* Tue Apr 7 2015 Remi Collet <remi@fedoraproject.org> - 4.6.2-1
+- Update to 4.6.2
+
* Fri Apr 3 2015 Remi Collet <remi@fedoraproject.org> - 4.6.1-1
- Update to 4.6.1
diff --git a/phpunit-rpm.patch b/phpunit-rpm.patch
index 724ad00..b927330 100644
--- a/phpunit-rpm.patch
+++ b/phpunit-rpm.patch
@@ -36,11 +36,12 @@ diff -up ./phpunit.rpm ./phpunit
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
--- ./tests/bootstrap.php.rpm 2015-01-17 12:24:41.000000000 +0100
+++ ./tests/bootstrap.php 2015-01-18 08:51:55.668966689 +0100
-@@ -1,6 +1,8 @@
+@@ -1,6 +1,9 @@
<?php
// Needed for isolated tests
-require __DIR__ . '/../vendor/autoload.php';
+require_once __DIR__ . '/_files/CoveredFunction.php';
++require_once __DIR__ . '/../PHPUnit/Framework/Assert/Functions.php';
+require_once __DIR__ . '/../PHPUnit/Autoload.php';
+require_once __DIR__ . '/autoload.php';