summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-08-17 18:16:01 +0200
committerRemi Collet <fedora@famillecollet.com>2014-08-17 18:16:01 +0200
commita6a4ee83326edfbbb74db6ad5ca0548e28ca7d75 (patch)
tree5e04d37f7a1e4fd95c453a3e79b53812e7711653
parent48c738779b51f4cb1367859659ab34c8d1e4e927 (diff)
php-phpunit-PHPUnit: 4.2.1
-rw-r--r--php-phpunit-PHPUnit.spec13
-rw-r--r--phpunit-rpm.patch6
2 files changed, 12 insertions, 7 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index da33aa6..280bf82 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 58db726aa45fe26bca93f692cb3d77e9a46b7830
+%global gh_commit e08a5b64400b9ca9124d38db30448d4b10b9f047
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -17,7 +17,7 @@
%global pear_channel pear.phpunit.de
Name: php-phpunit-PHPUnit
-Version: 4.2.0
+Version: 4.2.1
Release: 1%{?dist}
Summary: The PHP Unit Testing framework
@@ -143,12 +143,14 @@ for the creation, execution and analysis of Unit Tests.
%build
-phpab \
+%{_bindir}/php -d date.timezone=UTC \
+%{_bindir}/phpab \
--output src/Autoload.php \
--template %{SOURCE1} \
src
-phpab \
+%{_bindir}/php -d date.timezone=UTC \
+%{_bindir}/phpab \
--output tests/autoload.php \
tests
@@ -197,6 +199,9 @@ fi
%changelog
+* Sun Aug 17 2014 Remi Collet <remi@fedoraproject.org> - 4.2.1-1
+- Update to 4.2.1
+
* Mon Aug 11 2014 Remi Collet <remi@fedoraproject.org> - 4.2.0-1
- Update to 4.2.0
- raise dependency on phpunit/phpunit-mock-objects >= 2.2
diff --git a/phpunit-rpm.patch b/phpunit-rpm.patch
index 6c71e99..59e7ab9 100644
--- a/phpunit-rpm.patch
+++ b/phpunit-rpm.patch
@@ -30,8 +30,8 @@ diff -up ./phpunit.rpm ./phpunit
PHPUnit_TextUI_Command::main();
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2014-08-08 07:13:30.000000000 +0200
-+++ ./tests/bootstrap.php 2014-08-11 11:08:14.835209501 +0200
+--- ./tests/bootstrap.php.rpm 2014-08-17 17:36:46.325953778 +0200
++++ ./tests/bootstrap.php 2014-08-17 17:37:54.634043416 +0200
@@ -1,5 +1,8 @@
<?php
-require __DIR__ . '/../vendor/autoload.php';
@@ -41,4 +41,4 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
+require __DIR__ . '/autoload.php';
if (!ini_get('date.timezone') && !defined('HHVM_VERSION')) {
- echo PHP_EOL . 'Error: PHPUnit\'s test suite requires the "date.timezone" runtime configuration to be set. Please check your php.ini.' . PHP_EOL;
+ echo PHP_EOL . 'Error: PHPUnit\'s test suite requires the "date.timezone" runtime configuration to be set. Please check your php.ini.' . PHP_EOL;