summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-28 18:34:28 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-28 18:34:28 +0100
commit842fc5ff2ffca4131d86b3030643cb5def35bda4 (patch)
tree9f96b16d8b2b71bd2c33bb70f48d91024520e6ea
parentead17d39709aac19d81c739f15686157e324b0c9 (diff)
php-phpunit-PHPUnit: 5.6.7
-rw-r--r--composer.json2
-rwxr-xr-xmakesrc.sh31
-rw-r--r--php-phpunit-PHPUnit.spec11
3 files changed, 8 insertions, 36 deletions
diff --git a/composer.json b/composer.json
index f1f26d8..559932e 100644
--- a/composer.json
+++ b/composer.json
@@ -23,7 +23,7 @@
"php": "^5.6 || ^7.0",
"phpunit/php-file-iterator": "~1.4",
"phpunit/php-text-template": "~1.2",
- "phpunit/php-code-coverage": "^4.0.1",
+ "phpunit/php-code-coverage": "^4.0.3",
"phpunit/php-timer": "^1.0.6",
"phpunit/phpunit-mock-objects": "^3.2",
"phpspec/prophecy": "^1.3.1",
diff --git a/makesrc.sh b/makesrc.sh
deleted file mode 100755
index 34cf5ce..0000000
--- a/makesrc.sh
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/bin/bash
-
-NAME=$(basename $PWD)
-OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-MAJOR=$(sed -n '/^%global major/{s/.* //;p}' $NAME.spec)
-MINOR=$(sed -n '/^%global minor/{s/.* //;p}' $NAME.spec)
-VERSION=$MAJOR.$MINOR
-COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
-SHORT=${COMMIT:0:7}
-
-echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
-
-echo "Cloning..."
-rm -rf $PROJECT-$COMMIT
-git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
-
-echo "Getting commit..."
-pushd $PROJECT-$COMMIT
-rm -r build
-git checkout $COMMIT
-cp composer.json ../composer.json
-popd
-
-echo "Archiving..."
-tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
-
-echo "Cleaning..."
-rm -rf $PROJECT-$COMMIT
-
-echo "Done."
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 8f2fc11..dbcf049 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 875145fabfa261fa9c1aea663dd29ddce92dca8f
+%global gh_commit 38810e97481723ef918f6e35c03cb1014a645bd5
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -17,7 +17,7 @@
%global pear_name PHPUnit
%global pear_channel pear.phpunit.de
%global major 5.6
-%global minor 5
+%global minor 7
%global specrel 1
Name: php-phpunit-PHPUnit
@@ -71,7 +71,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "php": "^5.6 || ^7.0",
# "phpunit/php-file-iterator": "~1.4",
# "phpunit/php-text-template": "~1.2",
-# "phpunit/php-code-coverage": "^4.0.1",
+# "phpunit/php-code-coverage": "^4.0.3",
# "phpunit/php-timer": "^1.0.6",
# "phpunit/phpunit-mock-objects": "^3.2",
# "phpspec/prophecy": "^1.3.1",
@@ -96,7 +96,7 @@ Requires: php-composer(phpunit/php-file-iterator) >= 1.4
Requires: php-composer(phpunit/php-file-iterator) < 2
Requires: php-composer(phpunit/php-text-template) >= 1.2
Requires: php-composer(phpunit/php-text-template) < 2
-Requires: php-composer(phpunit/php-code-coverage) >= 4.0.1
+Requires: php-composer(phpunit/php-code-coverage) >= 4.0.3
Requires: php-composer(phpunit/php-code-coverage) < 5
Requires: php-composer(phpunit/php-timer) >= 1.0.6
Requires: php-composer(phpunit/php-timer) < 2
@@ -236,6 +236,9 @@ fi
%changelog
+* Mon Nov 28 2016 Remi Collet <remi@fedoraproject.org> - 5.6.7-1
+- update to 5.6.7
+
* Tue Nov 22 2016 Remi Collet <remi@fedoraproject.org> - 5.6.5-1
- update to 5.6.5
- raise dependency on sebastian/comparator 1.2.2