summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-07 11:35:06 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-07 11:35:06 +0200
commit6084b177224cbea57eafc9de2bc17fb3a2850818 (patch)
treed62daf0281354e08b788c9917c4832f8ab3ba12e
parent9650e43d3cda56bd3c663562d79627bda37e68b2 (diff)
php-phpunit-PHPUnit: 5.3.1
-rw-r--r--composer-dev.json76
-rw-r--r--composer.json74
-rw-r--r--php-phpunit-PHPUnit-dev.spec9
3 files changed, 156 insertions, 3 deletions
diff --git a/composer-dev.json b/composer-dev.json
new file mode 100644
index 0000000..d1a66c6
--- /dev/null
+++ b/composer-dev.json
@@ -0,0 +1,76 @@
+{
+ "name": "phpunit/phpunit",
+ "description": "The PHP Unit Testing framework.",
+ "type": "library",
+ "keywords": [
+ "phpunit",
+ "xunit",
+ "testing"
+ ],
+ "homepage": "https://phpunit.de/",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/phpunit/issues"
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "phpunit/php-file-iterator": "~1.4",
+ "phpunit/php-text-template": "~1.2",
+ "phpunit/php-code-coverage": "^3.3.0",
+ "phpunit/php-timer": "^1.0.6",
+ "phpunit/phpunit-mock-objects": "^3.1",
+ "phpspec/prophecy": "^1.3.1",
+ "symfony/yaml": "~2.1|~3.0",
+ "sebastian/comparator": "~1.1",
+ "sebastian/diff": "~1.2",
+ "sebastian/environment": "~1.3",
+ "sebastian/exporter": "~1.2",
+ "sebastian/global-state": "~1.0",
+ "sebastian/object-enumerator": "~1.0",
+ "sebastian/resource-operations": "~1.0",
+ "sebastian/version": "~1.0|~2.0",
+ "myclabs/deep-copy": "~1.3",
+ "ext-dom": "*",
+ "ext-json": "*",
+ "ext-pcre": "*",
+ "ext-reflection": "*",
+ "ext-spl": "*"
+ },
+ "config": {
+ "platform": {
+ "php": "5.6.0"
+ }
+ },
+ "suggest": {
+ "phpunit/php-invoker": "~1.1"
+ },
+ "bin": [
+ "phpunit"
+ ],
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "autoload-dev": {
+ "classmap": [
+ "tests/"
+ ],
+ "files": [
+ "src/Framework/Assert/Functions.php",
+ "tests/_files/CoveredFunction.php"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "5.3.x-dev"
+ }
+ }
+}
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..4a77446
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,74 @@
+{
+ "name": "phpunit/phpunit",
+ "description": "The PHP Unit Testing framework.",
+ "type": "library",
+ "keywords": [
+ "phpunit",
+ "xunit",
+ "testing"
+ ],
+ "homepage": "https://phpunit.de/",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/phpunit/issues",
+ "irc": "irc://irc.freenode.net/phpunit"
+ },
+ "require": {
+ "php": ">=5.3.3",
+ "phpunit/php-file-iterator": "~1.4",
+ "phpunit/php-text-template": "~1.2",
+ "phpunit/php-code-coverage": "~2.1",
+ "phpunit/php-timer": ">=1.0.6",
+ "phpunit/phpunit-mock-objects": "~2.3",
+ "phpspec/prophecy": "^1.3.1",
+ "symfony/yaml": "~2.1|~3.0",
+ "sebastian/comparator": "~1.1",
+ "sebastian/diff": "~1.2",
+ "sebastian/environment": "~1.3",
+ "sebastian/exporter": "~1.2",
+ "sebastian/global-state": "~1.0",
+ "sebastian/version": "~1.0",
+ "ext-dom": "*",
+ "ext-json": "*",
+ "ext-pcre": "*",
+ "ext-reflection": "*",
+ "ext-spl": "*"
+ },
+ "config": {
+ "platform": {
+ "php": "5.3.3"
+ }
+ },
+ "suggest": {
+ "phpunit/php-invoker": "~1.1"
+ },
+ "bin": [
+ "phpunit"
+ ],
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "autoload-dev": {
+ "classmap": [
+ "tests/"
+ ],
+ "files": [
+ "src/Framework/Assert/Functions.php",
+ "tests/_files/CoveredFunction.php"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "4.8.x-dev"
+ }
+ }
+}
diff --git a/php-phpunit-PHPUnit-dev.spec b/php-phpunit-PHPUnit-dev.spec
index 31a930b..a75b316 100644
--- a/php-phpunit-PHPUnit-dev.spec
+++ b/php-phpunit-PHPUnit-dev.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit dd3001822b2df8f5add266020e3d2fd3c5db3ae9
+%global gh_commit 34a3acb401ae79deb37bc6e5f5ec3d325b369b4c
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -17,7 +17,7 @@
%global pear_name PHPUnit
%global pear_channel pear.phpunit.de
%global major 5.3
-%global minor 0
+%global minor 1
%global specrel 1
Name: php-phpunit-PHPUnit
@@ -65,7 +65,7 @@ BuildRequires: php-composer(phpunit/php-invoker) >= 1.1.0
# "phpunit/php-file-iterator": "~1.4",
# "phpunit/php-text-template": "~1.2",
# "phpunit/php-code-coverage": "^3.3.0",
-# "phpunit/php-timer": ">=1.0.6",
+# "phpunit/php-timer": "^1.0.6",
# "phpunit/phpunit-mock-objects": "^3.1",
# "phpspec/prophecy": "^1.3.1",
# "symfony/yaml": "~2.1|~3.0",
@@ -219,6 +219,9 @@ fi
%changelog
+* Thu Apr 7 2016 Remi Collet <remi@fedoraproject.org> - 5.3.1-1
+- Update to 5.3.1
+
* Fri Apr 1 2016 Remi Collet <remi@fedoraproject.org> - 5.3.0-1
- Update to 5.3.0
- add dependency on sebastian/object-enumerator