summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-14 15:53:55 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-14 15:53:55 +0200
commit44543ff6ad5f95163ee0dbe24e51f1fbba7464a5 (patch)
tree576da9a44e78f8bcc72eaa670bb094e407a4e7d4
parente12a4565cf4a18b1c45e35125f9d87daa0ad3d2e (diff)
php-phpunit-PHPUnit: 4.2.6
-rw-r--r--php-phpunit-PHPUnit.spec7
-rw-r--r--phpunit-rpm.patch12
2 files changed, 12 insertions, 7 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index edec6ef..a6e78ed 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit c3abe5953d1e60a0bf23012b1bc8c4d07f4832d7
+%global gh_commit c28a790620fe30b049bb693be1ef9cd4e0fe906c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -17,7 +17,7 @@
%global pear_channel pear.phpunit.de
Name: php-phpunit-PHPUnit
-Version: 4.2.5
+Version: 4.2.6
Release: 1%{?dist}
Summary: The PHP Unit Testing framework
@@ -199,6 +199,9 @@ fi
%changelog
+* Sun Sep 14 2014 Remi Collet <remi@fedoraproject.org> - 4.2.6-1
+- Update to 4.2.6 (no change)
+
* Sun Sep 7 2014 Remi Collet <remi@fedoraproject.org> - 4.2.5-1
- Update to 4.2.5 (no change)
diff --git a/phpunit-rpm.patch b/phpunit-rpm.patch
index 59e7ab9..f953d8d 100644
--- a/phpunit-rpm.patch
+++ b/phpunit-rpm.patch
@@ -1,16 +1,16 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2014-08-08 07:13:30.000000000 +0200
-+++ ./phpunit 2014-08-11 11:12:26.435360930 +0200
+--- ./phpunit.rpm 2014-09-14 11:31:24.000000000 +0200
++++ ./phpunit 2014-09-14 15:48:32.804943481 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env php
+#!/usr/bin/php
<?php
/* PHPUnit
*
-@@ -35,20 +35,7 @@
+@@ -35,22 +35,7 @@
* POSSIBILITY OF SUCH DAMAGE.
*/
-
+
-foreach (array(__DIR__ . '/../../autoload.php', __DIR__ . '/vendor/autoload.php') as $file) {
- if (file_exists($file)) {
- define('PHPUNIT_COMPOSER_INSTALL', $file);
@@ -18,6 +18,8 @@ diff -up ./phpunit.rpm ./phpunit
- }
-}
-
+-unset($file);
+-
-if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
- echo 'You need to set up the project dependencies using the following commands:' . PHP_EOL .
- 'wget http://getcomposer.org/composer.phar' . PHP_EOL .
@@ -27,7 +29,7 @@ diff -up ./phpunit.rpm ./phpunit
-
+define ('PHPUNIT_COMPOSER_INSTALL', stream_resolve_include_path('PHPUnit/Autoload.php'));
require PHPUNIT_COMPOSER_INSTALL;
-
+
PHPUnit_TextUI_Command::main();
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
--- ./tests/bootstrap.php.rpm 2014-08-17 17:36:46.325953778 +0200