summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-10 13:27:42 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-10 13:27:42 +0200
commit28025a31d54a9cebe3face2c327b094bd113c076 (patch)
treedec292d19d7b2af73704afc99c061219030b75d4
parent9b70946c2e42495f7395198617f16965cdbd99e8 (diff)
php-phpunit-PHPUnit: 4.8.3
-rw-r--r--php-phpunit-PHPUnit.spec7
-rw-r--r--phpunit-rpm.patch19
2 files changed, 16 insertions, 10 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index b6b67ac..34033e0 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 748c6963c0a8c983fa69ee8884c885d0e98209bf
+%global gh_commit fd3050e26e3105f416d74c4d33aea659b406c59d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -16,7 +16,7 @@
%global pear_name PHPUnit
%global pear_channel pear.phpunit.de
%global major 4.8
-%global minor 2
+%global minor 3
Name: php-phpunit-PHPUnit
Version: %{major}.%{minor}
@@ -202,6 +202,9 @@ fi
%changelog
+* Mon Aug 10 2015 Remi Collet <remi@fedoraproject.org> - 4.8.3-1
+- Update to 4.8.3
+
* Fri Aug 7 2015 Remi Collet <remi@fedoraproject.org> - 4.8.2-1
- Update to 4.8.2
diff --git a/phpunit-rpm.patch b/phpunit-rpm.patch
index 46fd1ea..5f41e7e 100644
--- a/phpunit-rpm.patch
+++ b/phpunit-rpm.patch
@@ -1,12 +1,14 @@
---- ./phpunit.rpm 2015-05-25 07:18:18.000000000 +0200
-+++ ./phpunit 2015-05-26 19:43:34.101986869 +0200
-@@ -13,22 +13,21 @@
+diff -up ./phpunit.rpm ./phpunit
+--- ./phpunit.rpm 2015-08-10 13:22:08.674131079 +0200
++++ ./phpunit 2015-08-10 13:23:53.882702518 +0200
+@@ -22,24 +22,21 @@ if (!ini_get('date.timezone')) {
ini_set('date.timezone', 'UTC');
}
-
+
-foreach (array(__DIR__ . '/../../autoload.php', __DIR__ . '/../vendor/autoload.php', __DIR__ . '/vendor/autoload.php') as $file) {
- if (file_exists($file)) {
- define('PHPUNIT_COMPOSER_INSTALL', $file);
+-
- break;
- }
+// Ensure correct include_path for RHSCL
@@ -17,7 +19,7 @@
+ set_include_path(implode(':', $dirs));
}
+unset ($inc, $dirs);
-
+
-unset($file);
-
-if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
@@ -26,6 +28,7 @@
- 'wget http://getcomposer.org/composer.phar' . PHP_EOL .
- 'php composer.phar install' . PHP_EOL
- );
+-
- die(1);
+// Libraries PATH
+if (file_exists('./vendor/phpunit/phpunit/phpunit') && file_exists('./vendor/autoload.php')) {
@@ -34,11 +37,11 @@
+} else {
+ define ('PHPUNIT_COMPOSER_INSTALL', stream_resolve_include_path('PHPUnit/Autoload.php'));
}
-
+
require PHPUNIT_COMPOSER_INSTALL;
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2015-01-17 12:24:41.000000000 +0100
-+++ ./tests/bootstrap.php 2015-01-18 08:51:55.668966689 +0100
+--- ./tests/bootstrap.php.rpm 2015-08-10 11:16:56.000000000 +0200
++++ ./tests/bootstrap.php 2015-08-10 13:22:08.674131079 +0200
@@ -1,6 +1,9 @@
<?php
// Needed for isolated tests