summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-26 09:04:04 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-26 09:04:04 +0200
commit24a5f7d8bf23dbdd713da4ee2eba0584cd4ff080 (patch)
tree0bcecb4bc39f6d4baa8a6312e28dca77f503d3bc
parentdab18d7526cbc62151a381849083ed3b0b62e7aa (diff)
php-phpunit-PHPUnit: detect and redirect to composer installed version #1157910
-rw-r--r--php-phpunit-PHPUnit.spec5
-rw-r--r--phpunit-rpm.patch16
2 files changed, 13 insertions, 8 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 4d1e0d3..98ff086 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -18,7 +18,7 @@
Name: php-phpunit-PHPUnit
Version: 4.6.7
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: The PHP Unit Testing framework
Group: Development/Libraries
@@ -204,6 +204,9 @@ fi
%changelog
+* Tue May 26 2015 Remi Collet <remi@fedoraproject.org> - 4.6.7-2
+- detect and redirect to composer installed version #1157910
+
* Mon May 25 2015 Remi Collet <remi@fedoraproject.org> - 4.6.7-1
- Update to 4.6.7 (no change)
diff --git a/phpunit-rpm.patch b/phpunit-rpm.patch
index 03ace66..7392971 100644
--- a/phpunit-rpm.patch
+++ b/phpunit-rpm.patch
@@ -1,10 +1,10 @@
diff -up ./phpunit.rpm ./phpunit
--- ./phpunit.rpm 2015-01-17 12:24:41.000000000 +0100
+++ ./phpunit 2015-01-18 08:52:50.896228541 +0100
-@@ -13,24 +13,7 @@ if (!ini_get('date.timezone')) {
+@@ -13,22 +13,11 @@
ini_set('date.timezone', 'UTC');
}
-
+
-foreach (array(__DIR__ . '/../../autoload.php', __DIR__ . '/../vendor/autoload.php', __DIR__ . '/vendor/autoload.php') as $file) {
- if (file_exists($file)) {
- define('PHPUNIT_COMPOSER_INSTALL', $file);
@@ -21,12 +21,14 @@ diff -up ./phpunit.rpm ./phpunit
- 'php composer.phar install' . PHP_EOL
- );
- die(1);
--}
--
-+define ('PHPUNIT_COMPOSER_INSTALL', stream_resolve_include_path('PHPUnit/Autoload.php'));
++if (file_exists('./vendor/phpunit/phpunit/phpunit') && file_exists('./vendor/autoload.php')) {
++ echo "\n==== Redirecting to composer installed version in vendor/phpunit ====\n\n";
++ define ('PHPUNIT_COMPOSER_INSTALL', realpath('./vendor/autoload.php'));
++} else {
++ define ('PHPUNIT_COMPOSER_INSTALL', stream_resolve_include_path('PHPUnit/Autoload.php'));
+ }
+
require PHPUNIT_COMPOSER_INSTALL;
-
- PHPUnit_TextUI_Command::main();
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
--- ./tests/bootstrap.php.rpm 2015-01-17 12:24:41.000000000 +0100
+++ ./tests/bootstrap.php 2015-01-18 08:51:55.668966689 +0100