summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-10-08 07:25:29 +0200
committerRemi Collet <fedora@famillecollet.com>2014-10-08 07:25:29 +0200
commit10e8c922d30528cbf864001130265b91d4f8b627 (patch)
tree03118cded3d845cd359f95e292c1561374d39183
parent70262def77dae5cd9ec78b673d0c98a96a22d2d4 (diff)
php-phpunit-PHPUnit: new upstream patch for "no colors" patch, raise dependency on sebastian/environment >= 1.1
-rw-r--r--php-phpunit-PHPUnit.spec12
-rw-r--r--phpunit-colors.patch77
2 files changed, 49 insertions, 40 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 2911bfc..6126bb9 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -18,7 +18,7 @@
Name: php-phpunit-PHPUnit
Version: 4.3.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: The PHP Unit Testing framework
Group: Development/Libraries
@@ -45,7 +45,7 @@ BuildRequires: php-composer(phpunit/php-timer) >= 1.0.2
BuildRequires: php-composer(phpunit/phpunit-mock-objects) >= 2.3
BuildRequires: php-composer(sebastian/comparator) >= 1.0
BuildRequires: php-composer(sebastian/diff) >= 1.1
-BuildRequires: php-composer(sebastian/environment) >= 1.0
+BuildRequires: php-composer(sebastian/environment) >= 1.1
BuildRequires: php-composer(sebastian/exporter) >= 1.0
BuildRequires: php-composer(sebastian/version) >= 1.0
BuildRequires: php-composer(symfony/yaml) >= 2.0
@@ -62,7 +62,7 @@ BuildRequires: php-composer(phpunit/php-invoker) >= 1.1.0
# "symfony/yaml": "~2.0",
# "sebastian/comparator": "~1.0",
# "sebastian/diff": "~1.1",
-# "sebastian/environment": "~1.0",
+# "sebastian/environment": "~1.1",
# "sebastian/exporter": "~1.0",
# "sebastian/version": "~1.0",
# "ext-dom": "*",
@@ -85,7 +85,7 @@ Requires: php-composer(sebastian/comparator) >= 1.0
Requires: php-composer(sebastian/comparator) < 2
Requires: php-composer(sebastian/diff) >= 1.1
Requires: php-composer(sebastian/diff) < 2
-Requires: php-composer(sebastian/environment) >= 1.0
+Requires: php-composer(sebastian/environment) >= 1.1
Requires: php-composer(sebastian/environment) < 2
Requires: php-composer(sebastian/exporter) >= 1.0
Requires: php-composer(sebastian/exporter) < 2
@@ -200,6 +200,10 @@ fi
%changelog
+* Wed Oct 8 2014 Remi Collet <remi@fedoraproject.org> - 4.3.1-2
+- new upstream patch for "no colors" patch
+- raise dependency on sebastian/environment >= 1.1
+
* Mon Oct 6 2014 Remi Collet <remi@fedoraproject.org> - 4.3.1-1
- Update to 4.3.1 (no change)
diff --git a/phpunit-colors.patch b/phpunit-colors.patch
index 847d46c..9c0a8f9 100644
--- a/phpunit-colors.patch
+++ b/phpunit-colors.patch
@@ -1,42 +1,47 @@
-From 591efd8fad55a526f021cad9c6cbcd9081df8969 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Mon, 6 Oct 2014 10:54:54 +0200
-Subject: [PATCH] only enable colors when output to a terminal (not to a file)
+From 3d56c46afb9ed10b0d248fb0ea698aa22d939421 Mon Sep 17 00:00:00 2001
+From: Sebastian Bergmann <sb@sebastian-bergmann.de>
+Date: Tue, 7 Oct 2014 11:29:29 +0200
+Subject: [PATCH] Rework 591efd8fad55a526f021cad9c6cbcd9081df8969
---
- src/TextUI/Command.php | 7 +++++--
- src/Util/Configuration.php | 3 +++
- 2 files changed, 8 insertions(+), 2 deletions(-)
+ composer.json | 2 +-
+ src/TextUI/ResultPrinter.php | 6 +++++-
+ 2 files changed, 6 insertions(+), 2 deletions(-)
-diff --git a/src/TextUI/Command.php b/src/TextUI/Command.php
-index 929ca36..42b08b6 100644
---- a/src/TextUI/Command.php
-+++ b/src/TextUI/Command.php
-@@ -278,8 +278,11 @@ protected function handleArguments(array $argv)
+diff --git a/composer.json b/composer.json
+index 9dc9950..ae6ff27 100644
+--- a/composer.json
++++ b/composer.json
+@@ -30,7 +30,7 @@
+ "symfony/yaml": "~2.0",
+ "sebastian/comparator": "~1.0",
+ "sebastian/diff": "~1.1",
+- "sebastian/environment": "~1.0",
++ "sebastian/environment": "~1.1",
+ "sebastian/exporter": "~1.0",
+ "sebastian/version": "~1.0",
+ "ext-dom": "*",
+diff --git a/src/TextUI/ResultPrinter.php b/src/TextUI/ResultPrinter.php
+index ca16c8a..e701e33 100644
+--- a/src/TextUI/ResultPrinter.php
++++ b/src/TextUI/ResultPrinter.php
+@@ -43,6 +43,8 @@
+ * @since File available since Release 2.0.0
+ */
- foreach ($this->options[0] as $option) {
- switch ($option[0]) {
-- case '--colors': {
-- $this->arguments['colors'] = true;
-+ case '--colors':
-+ if (function_exists("posix_isatty") && !posix_isatty(STDOUT)) {
-+ $this->arguments['colors'] = false;
-+ } else {
-+ $this->arguments['colors'] = true;
- }
- break;
-
-diff --git a/src/Util/Configuration.php b/src/Util/Configuration.php
-index 9ddcfb8..0fcc5fb 100644
---- a/src/Util/Configuration.php
-+++ b/src/Util/Configuration.php
-@@ -582,6 +582,9 @@ public function getPHPUnitConfiguration()
- $result['colors'] = $this->getBoolean(
- (string) $root->getAttribute('colors'), false
- );
-+ if ($result['colors'] && function_exists("posix_isatty") && !posix_isatty(STDOUT)) {
-+ $result['colors'] = false;
-+ }
++use SebastianBergmann\Environment\Console;
++
+ /**
+ * Prints the result of a TextUI TestRunner run.
+ *
+@@ -147,7 +149,9 @@ public function __construct($out = null, $verbose = false, $colors = false, $deb
}
- /**
+ if (is_bool($colors)) {
+- $this->colors = $colors;
++ $console = new Console;
++
++ $this->colors = $colors && $console->hasColorSupport();
+ } else {
+ throw PHPUnit_Util_InvalidArgumentHelper::factory(3, 'boolean');
+ }