summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-15 11:44:39 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-15 11:44:39 +0200
commit0f62ebf6aac9716d2f87c1b16a7f875e4639bbda (patch)
tree75848dbe271ca8df79e3e324013999401b295ab5
parent922214a776568cb529569320af5f76a1a3c1f45e (diff)
php-phpunit-PHPUnit: 5.4.5
-rw-r--r--composer-dev.json2
-rw-r--r--php-phpunit-PHPUnit-dev.spec15
2 files changed, 10 insertions, 7 deletions
diff --git a/composer-dev.json b/composer-dev.json
index 64d5285..0456889 100644
--- a/composer-dev.json
+++ b/composer-dev.json
@@ -30,7 +30,7 @@
"symfony/yaml": "~2.1|~3.0",
"sebastian/comparator": "~1.1",
"sebastian/diff": "~1.2",
- "sebastian/environment": "~1.3",
+ "sebastian/environment": "^1.3 || ^2.0",
"sebastian/exporter": "~1.2",
"sebastian/global-state": "~1.0",
"sebastian/object-enumerator": "~1.0",
diff --git a/php-phpunit-PHPUnit-dev.spec b/php-phpunit-PHPUnit-dev.spec
index 564b8d4..b2cff2f 100644
--- a/php-phpunit-PHPUnit-dev.spec
+++ b/php-phpunit-PHPUnit-dev.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 02d5b64aa0837a038a5a4faeeefa5ef44bdcb928
+%global gh_commit 744a50838ef373be00fb658ce9544905cf587c17
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -17,7 +17,7 @@
%global pear_name PHPUnit
%global pear_channel pear.phpunit.de
%global major 5.4
-%global minor 4
+%global minor 5
%global specrel 1
Name: php-phpunit-PHPUnit
@@ -71,7 +71,7 @@ BuildRequires: php-composer(phpunit/php-invoker) >= 1.1.0
# "symfony/yaml": "~2.1|~3.0",
# "sebastian/comparator": "~1.0",
# "sebastian/diff": "~1.2",
-# "sebastian/environment": "~1.3",
+# "sebastian/environment": "^1.3 || ^2.0",
# "sebastian/exporter": "~1.1",
# "sebastian/recursion-context": "~1.0",
# "sebastian/global-state": "~1.0",
@@ -103,7 +103,7 @@ Requires: php-composer(sebastian/comparator) < 2
Requires: php-composer(sebastian/diff) >= 1.2
Requires: php-composer(sebastian/diff) < 2
Requires: php-composer(sebastian/environment) >= 1.3
-Requires: php-composer(sebastian/environment) < 2
+Requires: php-composer(sebastian/environment) < 3
Requires: php-composer(sebastian/exporter) >= 1.2
Requires: php-composer(sebastian/exporter) < 2
Requires: php-composer(sebastian/global-state) >= 1.0
@@ -193,8 +193,8 @@ install -D -p -m 755 phpunit %{buildroot}%{_bindir}/phpunit
%check
./phpunit --testsuite=small --no-coverage --verbose
-if which php70; then
- php70 ./phpunit --testsuite=small --no-coverage --verbose
+if which php71; then
+ php71 ./phpunit --testsuite=small --no-coverage --verbose
fi
@@ -220,6 +220,9 @@ fi
%changelog
+* Wed Jun 15 2016 Remi Collet <remi@fedoraproject.org> - 5.4.5-1
+- Update to 5.4.5
+
* Thu Jun 9 2016 Remi Collet <remi@fedoraproject.org> - 5.4.4-1
- Update to 5.4.4