summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--autoload.php.in1
-rw-r--r--php-phpunit-PHPUnit-SkeletonGenerator.spec15
2 files changed, 10 insertions, 6 deletions
diff --git a/autoload.php.in b/autoload.php.in
index ed4d26b..bc903fc 100644
--- a/autoload.php.in
+++ b/autoload.php.in
@@ -12,6 +12,7 @@ $loader = new Symfony\Component\ClassLoader\UniversalClassLoader();
$loader->registerNamespaces(array(
'Symfony\\Component\\Console' => $phpdir,
'Symfony\\Component\\ClassLoader' => $phpdir,
+ 'org\\bovigo\\vfs' => $phpdir,
));
$loader->register();
diff --git a/php-phpunit-PHPUnit-SkeletonGenerator.spec b/php-phpunit-PHPUnit-SkeletonGenerator.spec
index f947eb8..43548e3 100644
--- a/php-phpunit-PHPUnit-SkeletonGenerator.spec
+++ b/php-phpunit-PHPUnit-SkeletonGenerator.spec
@@ -13,12 +13,11 @@
%global php_home %{_datadir}/php
%global pear_name PHPUnit_SkeletonGenerator
%global pear_channel pear.phpunit.de
-# Missing dep to run test
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-phpunit-PHPUnit-SkeletonGenerator
Version: 2.0.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Tool that can generate skeleton test classes
Group: Development/Libraries
@@ -42,7 +41,7 @@ BuildRequires: php-phpunit-Text-Template >= 1.2
BuildRequires: php-phpunit-Version >= 1.0
BuildRequires: php-symfony-console >= 2.4
BuildRequires: php-symfony-classloader >= 2.4
-# BuildRequires: "mikey179/vfsStream": "~1.2"
+BuildRequires: php-mikey179-vfsstream >= 1.2
%endif
# From composer.json
@@ -93,10 +92,10 @@ rm -rf %{buildroot}
%if %{with_tests}
%check
+cd build
phpunit \
-d date.timezone=UTC \
- --bootstrap src/autoload.php \
- tests
+ --bootstrap ../src/autoload.php
%endif
@@ -117,6 +116,10 @@ fi
%changelog
+* Tue May 13 2014 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
+- add BR on php-mikey179-vfsstream
+- enable test during build
+
* Tue May 13 2014 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
- update to 2.0.0
- add generated autoloader