summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore9
-rw-r--r--php-phpunit-PHPUnit-Selenium.spec26
2 files changed, 21 insertions, 14 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..6f69818
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-phpunit-PHPUnit-Selenium.spec b/php-phpunit-PHPUnit-Selenium.spec
index 2e5888d..4ef92db 100644
--- a/php-phpunit-PHPUnit-Selenium.spec
+++ b/php-phpunit-PHPUnit-Selenium.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-PHPUnit-Selenium
#
-# Copyright (c) 2010-2017 Remi Collet
+# Copyright (c) 2010-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,15 +17,13 @@
Name: php-phpunit-PHPUnit-Selenium
Version: 3.0.3
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: Selenium RC integration for PHPUnit
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-fedora-autoloader-devel
@@ -37,10 +35,13 @@ BuildRequires: php-fedora-autoloader-devel
# "ext-curl": "*",
# "ext-dom": "*"
Requires: php(language) >= 5.6
-Requires: php-composer(phpunit/phpunit) >= 5
-Requires: php-composer(phpunit/phpunit) < 6
-Requires: php-composer(sebastian/comparator) >= 1.0
-Requires: php-composer(sebastian/comparator) < 2
+%if 0%{?fedora} >= 27
+Requires: (php-composer(phpunit/phpunit) >= 5 with php-composer(phpunit/phpunit) < 6)
+Requires: (php-composer(sebastian/comparator) >= 1.0 with php-composer(sebastian/comparator) < 2)
+%else
+Requires: php-phpunit-PHPUnit >= 5
+Requires: php-phpunit-comparator
+%endif
Requires: php-curl
Requires: php-dom
# From phpcompatinfo report for version 1.3.3
@@ -88,15 +89,10 @@ EOF
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}
cp -pr PHPUnit %{buildroot}%{php_home}/PHPUnit
-%clean
-rm -rf %{buildroot}
-
-
%post
if [ -x %{_bindir}/pear ]; then
%{_bindir}/pear uninstall --nodeps --ignore-errors --register-only \
@@ -105,7 +101,6 @@ fi
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc ChangeLog.markdown README.md
@@ -114,6 +109,9 @@ fi
%changelog
+* Tue Feb 6 2018 Remi Collet <remi@fedoraproject.org> - 3.0.3-4
+- use range dependencies on F27+
+
* Tue Jan 24 2017 Remi Collet <remi@fedoraproject.org> - 3.0.3-1
- update to 3.0.3
- switch to fedora/autoloader