summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHPUnit-MockObject.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-PHPUnit-MockObject.spec')
-rw-r--r--php-phpunit-PHPUnit-MockObject.spec19
1 files changed, 14 insertions, 5 deletions
diff --git a/php-phpunit-PHPUnit-MockObject.spec b/php-phpunit-PHPUnit-MockObject.spec
index 6b654f6..ae744e3 100644
--- a/php-phpunit-PHPUnit-MockObject.spec
+++ b/php-phpunit-PHPUnit-MockObject.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-PHPUnit-MockObject
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,7 +17,6 @@
%global pear_channel pear.phpunit.de
%global major 3.4
%global minor 4
-%global specrel 5
%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%else
@@ -26,7 +25,7 @@
Name: php-phpunit-PHPUnit-MockObject
Version: %{major}.%{minor}
-Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Release: 6%{?dist}
Summary: Mock Object library for PHPUnit
License: BSD
@@ -37,6 +36,8 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
Patch0: %{gh_project}-3.0.0-rpm.patch
# For 7.4
Patch1: %{gh_project}-php74.patch
+# For 8.0
+Patch2: %{gh_project}-php80.patch
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
@@ -97,6 +98,7 @@ Mock Object library for PHPUnit
%patch0 -p0
%patch1 -p1
+%patch2 -p1
find . -name \*.orig -exec rm {} \; -print
@@ -133,12 +135,16 @@ cat <<EOF >>tests/bootstrap.php
require __DIR__ . '/_fixture/autoload.php';
EOF
+FILTER="testGetMockForSingletonWithReflectionSuccess"
+
: Run tests - set include_path to ensure PHPUnit autoloader use it
ret=0
-for cmd in php php70 php71 php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
- %{_bindir}/phpunit --no-coverage || ret=1
+ %{_bindir}/phpunit \
+ --filter "^((?!($FILTER)).)*$" \
+ --no-coverage || ret=1
fi
done
exit $ret
@@ -162,6 +168,9 @@ fi
%changelog
+* Thu Mar 18 2021 Remi Collet <remi@remirepo.net> - 3.4.4-6
+- fix more deprecated usages
+
* Wed Aug 21 2019 Remi Collet <remi@remirepo.net> - 3.4.4-5
- fix deprecated usage of ReflectionType::__toString()