summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-10-03 19:28:29 +0200
committerRemi Collet <fedora@famillecollet.com>2014-10-03 19:28:29 +0200
commit8d9b5d7a8f7a43c2c7f224f6ba655a919cd20f89 (patch)
treeabc9f8629f0542e8dd69e777cab57aab81237c48
parentaa843a587089b8038123a55b0ef55f6f445ce5ab (diff)
php-phpunit-PHPUnit-MockObject: typo
-rw-r--r--php-phpunit-PHPUnit-MockObject.spec2
-rw-r--r--phpunit-mock-objects-upstream.patch23
2 files changed, 1 insertions, 24 deletions
diff --git a/php-phpunit-PHPUnit-MockObject.spec b/php-phpunit-PHPUnit-MockObject.spec
index 815dd9a..404b687 100644
--- a/php-phpunit-PHPUnit-MockObject.spec
+++ b/php-phpunit-PHPUnit-MockObject.spec
@@ -47,8 +47,8 @@ BuildRequires: php-pear-PHPUnit >= 4.3.0
# From composer.json
# "php": ">=5.3.3",
+# "phpunit/php-text-template": "~1.2",
# "doctrine/instantiator": "~1.0,>=1.0.1",
-# "ocramius/instantiator": "~1.0"
Requires: php(language) >= 5.3.3
Requires: php-composer(phpunit/php-text-template) >= 1.2
Requires: php-composer(phpunit/php-text-template) < 2
diff --git a/phpunit-mock-objects-upstream.patch b/phpunit-mock-objects-upstream.patch
deleted file mode 100644
index 846679b..0000000
--- a/phpunit-mock-objects-upstream.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From fe3dc6c5d6a8998ae917aed0b2f09fd4cdde16ba Mon Sep 17 00:00:00 2001
-From: Jeff Welch <whatthejeff@gmail.com>
-Date: Sat, 6 Sep 2014 13:37:44 -0400
-Subject: [PATCH] Refs #197: Skip variadics test on PHP < 5.6.0.
-
----
- tests/MockObject/class_with_method_with_variadic_arguments.phpt | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/tests/MockObject/class_with_method_with_variadic_arguments.phpt b/tests/MockObject/class_with_method_with_variadic_arguments.phpt
-index bb38da7..8fb9a3c 100644
---- a/tests/MockObject/class_with_method_with_variadic_arguments.phpt
-+++ b/tests/MockObject/class_with_method_with_variadic_arguments.phpt
-@@ -1,5 +1,9 @@
- --TEST--
- PHPUnit_Framework_MockObject_Generator::generate('ClassWithMethodWithVariadicArguments', array(), 'MockFoo', TRUE, TRUE)
-+--SKIPIF--
-+<?php
-+if (version_compare(PHP_VERSION, '5.6.0', '<')) print 'skip: PHP >= 5.6.0 required';
-+?>
- --FILE--
- <?php
- class ClassWithMethodWithVariadicArguments