summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-06 09:46:50 +0100
committerRemi Collet <remi@remirepo.net>2018-12-06 09:46:50 +0100
commit420afa990bf0f4614eed4f8ce33e600b82615880 (patch)
tree70ee0b402783a658bc2d0a3702c88b2b256e92ca
parent4777451148013f0b697c39fef328b526794bcb1c (diff)
cleanup for EL-8
-rw-r--r--php-phpunit-PHPUnit-MockObject.spec12
1 files changed, 7 insertions, 5 deletions
diff --git a/php-phpunit-PHPUnit-MockObject.spec b/php-phpunit-PHPUnit-MockObject.spec
index 0ae47b4..463d2ca 100644
--- a/php-phpunit-PHPUnit-MockObject.spec
+++ b/php-phpunit-PHPUnit-MockObject.spec
@@ -17,7 +17,7 @@
%global pear_channel pear.phpunit.de
%global major 3.4
%global minor 4
-%global specrel 3
+%global specrel 4
%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%else
@@ -29,7 +29,6 @@ Version: %{major}.%{minor}
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Mock Object library for PHPUnit
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
@@ -46,7 +45,7 @@ BuildRequires: php(language) >= 5.6
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^5.4"
BuildRequires: php-composer(phpunit/phpunit) >= 5.4
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpunit/php-text-template) >= 1.2 with php-composer(phpunit/php-text-template) < 2)
BuildRequires: (php-composer(doctrine/instantiator) >= 1.0.2 with php-composer(doctrine/instantiator) < 2)
BuildRequires: (php-composer(sebastian/exporter) >= 1.2 with php-composer(sebastian/exporter) < 3)
@@ -63,7 +62,7 @@ BuildRequires: php-phpunit-exporter >= 1.2
# "doctrine/instantiator": "^1.0.2",
# "sebastian/exporter": "^1.2 || ^2.0"
Requires: php(language) >= 5.6
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpunit/php-text-template) >= 1.2 with php-composer(phpunit/php-text-template) < 2)
Requires: (php-composer(doctrine/instantiator) >= 1.0.2 with php-composer(doctrine/instantiator) < 2)
Requires: (php-composer(sebastian/exporter) >= 1.2 with php-composer(sebastian/exporter) < 3)
@@ -135,7 +134,7 @@ EOF
: Run tests - set include_path to ensure PHPUnit autoloader use it
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
%{_bindir}/phpunit --no-coverage || ret=1
@@ -162,6 +161,9 @@ fi
%changelog
+* Thu Dec 6 2018 Remi Collet <remi@remirepo.net> - 3.4.4-4
+- cleanup for EL-8
+
* Fri Feb 2 2018 Remi Collet <remi@remirepo.net> - 3.4.4-3
- use range dependencies on F27+