summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-21 06:11:37 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-21 06:11:37 +0200
commit103d27bfa954a38f81f9360006403e7c9168c42a (patch)
tree55c879e8ffe301e9c85fe1ba906518457a159024
parentbe8c3ac451bc6bf04b588230e5bd16692ca62bfb (diff)
php-phpunit-PHPUnit-MockObject: 3.1.3
-rw-r--r--composer-dev.json50
-rw-r--r--composer.json50
-rw-r--r--php-phpunit-PHPUnit-MockObject-dev.spec7
3 files changed, 105 insertions, 2 deletions
diff --git a/composer-dev.json b/composer-dev.json
new file mode 100644
index 0000000..e4139e4
--- /dev/null
+++ b/composer-dev.json
@@ -0,0 +1,50 @@
+{
+ "name": "phpunit/phpunit-mock-objects",
+ "description": "Mock Object library for PHPUnit",
+ "type": "library",
+ "keywords": [
+ "xunit",
+ "mock"
+ ],
+ "homepage": "https://github.com/sebastianbergmann/phpunit-mock-objects/",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sb@sebastian-bergmann.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/phpunit-mock-objects/issues",
+ "irc": "irc://irc.freenode.net/phpunit"
+ },
+ "require": {
+ "php": ">=5.6",
+ "phpunit/php-text-template": "~1.2",
+ "doctrine/instantiator": "^1.0.2",
+ "sebastian/exporter": "~1.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~5"
+ },
+ "suggest": {
+ "ext-soap": "*"
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "autoload-dev": {
+ "classmap": [
+ "tests/_fixture/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.1.x-dev"
+ }
+ }
+}
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..12fb934
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,50 @@
+{
+ "name": "phpunit/phpunit-mock-objects",
+ "description": "Mock Object library for PHPUnit",
+ "type": "library",
+ "keywords": [
+ "xunit",
+ "mock"
+ ],
+ "homepage": "https://github.com/sebastianbergmann/phpunit-mock-objects/",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sb@sebastian-bergmann.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/phpunit-mock-objects/issues",
+ "irc": "irc://irc.freenode.net/phpunit"
+ },
+ "require": {
+ "php": ">=5.3.3",
+ "phpunit/php-text-template": "~1.2",
+ "doctrine/instantiator": "^1.0.2",
+ "sebastian/exporter": "~1.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4.4"
+ },
+ "suggest": {
+ "ext-soap": "*"
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "autoload-dev": {
+ "classmap": [
+ "tests/_fixture/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.3.x-dev"
+ }
+ }
+}
+
diff --git a/php-phpunit-PHPUnit-MockObject-dev.spec b/php-phpunit-PHPUnit-MockObject-dev.spec
index aba435c..2aab3d9 100644
--- a/php-phpunit-PHPUnit-MockObject-dev.spec
+++ b/php-phpunit-PHPUnit-MockObject-dev.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7c34c9bdde4131b824086457a3145e27dba10ca1
+%global gh_commit 151c96874bff6fe61a25039df60e776613a61489
#global gh_date 20150902
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -16,7 +16,7 @@
%global pear_name PHPUnit_MockObject
%global pear_channel pear.phpunit.de
%global major 3.1
-%global minor 2
+%global minor 3
%global specrel 1
%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
@@ -161,6 +161,9 @@ fi
%changelog
+* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 3.1.3-1
+- Update to 3.1.3
+
* Thu Mar 24 2016 Remi Collet <remi@fedoraproject.org> - 3.1.2-1
- Update to 3.1.2