summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHP-Timer.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:17:36 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:17:36 +0200
commiteef79751165c3f44169c419dbc4658df34f577d8 (patch)
treea104b3918626b539e6af7a4bc5581c0fe77b0bd1 /php-phpunit-PHP-Timer.spec
repo reorg
Diffstat (limited to 'php-phpunit-PHP-Timer.spec')
-rw-r--r--php-phpunit-PHP-Timer.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/php-phpunit-PHP-Timer.spec b/php-phpunit-PHP-Timer.spec
new file mode 100644
index 0000000..75da4ab
--- /dev/null
+++ b/php-phpunit-PHP-Timer.spec
@@ -0,0 +1,94 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name PHP_Timer
+%global channel pear.phpunit.de
+
+Name: php-phpunit-PHP-Timer
+Version: 1.0.2
+Release: 1%{?dist}
+Summary: PHP Utility class for timing
+
+Group: Development/Libraries
+License: BSD
+URL: http://github.com/sebastianbergmann/php-timer/
+Source0: http://pear.phpunit.de/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildArch: noarch
+BuildRequires: php-pear >= 1:1.9.2
+BuildRequires: php-channel(%{channel})
+Requires: php-channel(%{channel})
+Requires: php-common >= 5.2.7
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Provides: php-pear(%{channel}/%{pear_name}) = %{version}
+
+
+%description
+PHP Utility class for timing
+
+%prep
+%setup -q -c
+[ -f package2.xml ] || mv package.xml package2.xml
+%{__mv} package2.xml %{pear_name}-%{version}/%{name}.xml
+
+cd %{pear_name}-%{version}
+
+# Create a "localized" php.ini to avoid build warning
+cp /etc/php.ini .
+echo "date.timezone=UTC" >>php.ini
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__rm} -rf $RPM_BUILD_ROOT docdir
+PHPRC=./php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+%{__rm} -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+%{__mkdir} -p $RPM_BUILD_ROOT%{pear_xmldir}
+%{__install} -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%clean
+
+%{__rm} -rf $RPM_BUILD_ROOT
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/PHP
+
+%changelog
+* Sun Oct 23 2011 Remi Collet <rpms@famillecollet.com> 1.0.2-1
+- update to 1.0.2
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Sun Sep 26 2010 Christof Damian <christof@damian.net> - 1.0.0-2
+- fix timezone warnings
+
+* Thu Jul 15 2010 Christof Damian <christof@damian.net> - 1.0.0-1
+- initial package
+