summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHP-CodeCoverage.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-07 19:23:51 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-07 19:23:51 +0200
commitf95d67b6d373f328f3258677010dc447673b4d71 (patch)
treead2a64f55eb52d3faa836411507d2a824fb5f90c /php-phpunit-PHP-CodeCoverage.spec
php-phpunit-PHP-CodeCoverage: import from rawhide
Diffstat (limited to 'php-phpunit-PHP-CodeCoverage.spec')
-rw-r--r--php-phpunit-PHP-CodeCoverage.spec130
1 files changed, 130 insertions, 0 deletions
diff --git a/php-phpunit-PHP-CodeCoverage.spec b/php-phpunit-PHP-CodeCoverage.spec
new file mode 100644
index 0000000..660e069
--- /dev/null
+++ b/php-phpunit-PHP-CodeCoverage.spec
@@ -0,0 +1,130 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name PHP_CodeCoverage
+%global channel pear.phpunit.de
+
+Name: php-phpunit-PHP-CodeCoverage
+Version: 1.1.3
+Release: 1%{?dist}
+Summary: PHP code coverage information
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/sebastianbergmann/php-code-coverage
+Source0: http://pear.phpunit.de/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.9.4
+BuildRequires: php-channel(%{channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-xml >= 5.2.7
+Requires: php-pecl(Xdebug) >= 2.0.5
+Requires: php-pear(%{channel}/File_Iterator) >= 1.3.0
+Requires: php-pear(%{channel}/PHP_TokenStream) >= 1.1.0
+Requires: php-pear(%{channel}/Text_Template) >= 1.1.1
+Requires: php-pear(components.ez.no/ConsoleTools) >= 1.6
+
+Provides: php-pear(%{channel}/%{pear_name}) = %{version}
+
+%description
+Library that provides collection, processing, and rendering functionality
+for PHP code coverage information.
+
+
+%prep
+%setup -q -c
+cd %{pear_name}-%{version}
+# package.xml is V2
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/PHP
+
+
+%changelog
+* Wed Aug 01 2012 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
+- Version 1.1.3 (stable) - API 1.1.0 (stable)
+
+* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Thu Feb 23 2012 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
+- Version 1.1.2 (stable) - API 1.1.0 (stable)
+
+* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Fri Nov 04 2011 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- Version 1.1.1 (stable) - API 1.1.0 (stable)
+
+* Tue Nov 01 2011 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- Version 1.1.0 (stable) - API 1.1.0 (stable)
+- no more phpcov script in bindir
+
+* Fri Aug 19 2011 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
+- Version 1.0.5 (stable) - API 1.0.3 (stable)
+- remove PEAR hack (only needed for EPEL)
+- raise PEAR dependency to 1.9.2
+
+* Tue May 3 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.4-2
+- rebuild for doc in /usr/share/doc/pear
+
+* Wed Feb 16 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.4-1
+- Version 1.0.4 (stable) - API 1.0.3 (stable)
+- LICENSE CHANGELOG now provided by upstream
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Sun Jan 02 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.3-1
+- Version 1.0.3 (stable) - API 1.0.3 (stable)
+
+* Wed Nov 17 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.2-1
+- Version 1.0.2 (stable) - API 1.0.0 (stable)
+
+* Thu Nov 04 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-1.1
+- lower PEAR dependency to allow f13 and el6 build
+- fix URL
+
+* Sun Sep 26 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-1
+- initial generated spec + clean
+