summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-04 15:02:20 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-04 15:02:20 +0200
commit30eb55ad04f7a3b704e5fd653335dc5ad54eae34 (patch)
tree0309e8e374083b03dfbfaf0d7efaeb65574ee2c0
parent9830fb28a0ae37e442c46ad0497072cc350252cb (diff)
php-phpunit-PHP-CodeCoverage: add upstream patch (tests)
-rw-r--r--php-phpunit-PHP-CodeCoverage-dev.spec11
-rw-r--r--php-phpunit-PHP-CodeCoverage-upstream.patch134
2 files changed, 144 insertions, 1 deletions
diff --git a/php-phpunit-PHP-CodeCoverage-dev.spec b/php-phpunit-PHP-CodeCoverage-dev.spec
index 87cda6a..28398bc 100644
--- a/php-phpunit-PHP-CodeCoverage-dev.spec
+++ b/php-phpunit-PHP-CodeCoverage-dev.spec
@@ -18,7 +18,7 @@
%global pear_channel pear.phpunit.de
%global major 3.3
%global minor 1
-%global specrel 1
+%global specrel 2
%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%else
@@ -35,6 +35,9 @@ License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+# Fix for environment 1.3.6
+Patch0: %{name}-upstream.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.6
@@ -96,6 +99,8 @@ for PHP code coverage information.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
+
%build
phpab \
@@ -166,6 +171,10 @@ fi
%changelog
+* Wed May 4 2016 Remi Collet <remi@fedoraproject.org> - 3.3.1-2
+- add upstream patch for environment 1.3.6
+ https://github.com/sebastianbergmann/php-code-coverage/pull/435
+
* Fri Apr 8 2016 Remi Collet <remi@fedoraproject.org> - 3.3.1-1
- Update to 3.3.1
diff --git a/php-phpunit-PHP-CodeCoverage-upstream.patch b/php-phpunit-PHP-CodeCoverage-upstream.patch
new file mode 100644
index 0000000..a25a99b
--- /dev/null
+++ b/php-phpunit-PHP-CodeCoverage-upstream.patch
@@ -0,0 +1,134 @@
+From 5c8dd64bb3b3f4842933aa8c2876787b6c479229 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Wed, 4 May 2016 13:47:27 +0200
+Subject: [PATCH] fix for environment 1.3.6
+
+---
+ tests/_files/Report/HTML/CoverageForBankAccount/BankAccount.php.html | 2 +-
+ tests/_files/Report/HTML/CoverageForBankAccount/dashboard.html | 2 +-
+ tests/_files/Report/HTML/CoverageForBankAccount/index.html | 2 +-
+ .../Report/HTML/CoverageForClassWithAnonymousFunction/dashboard.html | 2 +-
+ .../_files/Report/HTML/CoverageForClassWithAnonymousFunction/index.html | 2 +-
+ .../source_with_class_and_anonymous_function.php.html | 2 +-
+ tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/dashboard.html | 2 +-
+ tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/index.html | 2 +-
+ .../HTML/CoverageForFileWithIgnoredLines/source_with_ignore.php.html | 2 +-
+ 9 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/tests/_files/Report/HTML/CoverageForBankAccount/BankAccount.php.html b/tests/_files/Report/HTML/CoverageForBankAccount/BankAccount.php.html
+index a5dcd4c..93ad3da 100644
+--- a/tests/_files/Report/HTML/CoverageForBankAccount/BankAccount.php.html
++++ b/tests/_files/Report/HTML/CoverageForBankAccount/BankAccount.php.html
+@@ -232,7 +232,7 @@
+ <span class="warning"><strong>Dead Code</strong></span>
+ </p>
+ <p>
+- <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http://php.net/" target="_top">%s</a> at %s.</small>
++ <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http%sphp.net/" target="_top">%s</a> at %s.</small>
+ </p>
+ <a title="Back to the top" id="toplink" href="#"><span class="glyphicon glyphicon-arrow-up"></span></a>
+ </footer>
+diff --git a/tests/_files/Report/HTML/CoverageForBankAccount/dashboard.html b/tests/_files/Report/HTML/CoverageForBankAccount/dashboard.html
+index 651217a..45f7aae 100644
+--- a/tests/_files/Report/HTML/CoverageForBankAccount/dashboard.html
++++ b/tests/_files/Report/HTML/CoverageForBankAccount/dashboard.html
+@@ -140,7 +140,7 @@
+ <footer>
+ <hr/>
+ <p>
+- <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http://php.net/" target="_top">%s</a> at %s.</small>
++ <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http%sphp.net/" target="_top">%s</a> at %s.</small>
+ </p>
+ </footer>
+ </div>
+diff --git a/tests/_files/Report/HTML/CoverageForBankAccount/index.html b/tests/_files/Report/HTML/CoverageForBankAccount/index.html
+index 5c99c2e..ae9e346 100644
+--- a/tests/_files/Report/HTML/CoverageForBankAccount/index.html
++++ b/tests/_files/Report/HTML/CoverageForBankAccount/index.html
+@@ -108,7 +108,7 @@
+ <span class="success"><strong>High</strong>: 90% to 100%</span>
+ </p>
+ <p>
+- <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http://php.net/" target="_top">%s</a> at %s.</small>
++ <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http%sphp.net/" target="_top">%s</a> at %s.</small>
+ </p>
+ </footer>
+ </div>
+diff --git a/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/dashboard.html b/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/dashboard.html
+index 229b167..9da9f55 100644
+--- a/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/dashboard.html
++++ b/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/dashboard.html
+@@ -138,7 +138,7 @@
+ <footer>
+ <hr/>
+ <p>
+- <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http://php.net/" target="_top">%s</a> at %s.</small>
++ <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http%sphp.net/" target="_top">%s</a> at %s.</small>
+ </p>
+ </footer>
+ </div>
+diff --git a/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/index.html b/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/index.html
+index ace676b..28007ce 100644
+--- a/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/index.html
++++ b/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/index.html
+@@ -108,7 +108,7 @@
+ <span class="success"><strong>High</strong>: 90% to 100%</span>
+ </p>
+ <p>
+- <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http://php.net/" target="_top">%s</a> at %s.</small>
++ <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http%sphp.net/" target="_top">%s</a> at %s.</small>
+ </p>
+ </footer>
+ </div>
+diff --git a/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/source_with_class_and_anonymous_function.php.html b/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/source_with_class_and_anonymous_function.php.html
+index ce90096..3892dce 100644
+--- a/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/source_with_class_and_anonymous_function.php.html
++++ b/tests/_files/Report/HTML/CoverageForClassWithAnonymousFunction/source_with_class_and_anonymous_function.php.html
+@@ -176,7 +176,7 @@
+ <span class="warning"><strong>Dead Code</strong></span>
+ </p>
+ <p>
+- <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http://php.net/" target="_top">%s</a> at %s.</small>
++ <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http%sphp.net/" target="_top">%s</a> at %s.</small>
+ </p>
+ <a title="Back to the top" id="toplink" href="#"><span class="glyphicon glyphicon-arrow-up"></span></a>
+ </footer>
+diff --git a/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/dashboard.html b/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/dashboard.html
+index 54deaea..6347182 100644
+--- a/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/dashboard.html
++++ b/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/dashboard.html
+@@ -136,7 +136,7 @@
+ <footer>
+ <hr/>
+ <p>
+- <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http://php.net/" target="_top">%s</a> at %s.</small>
++ <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http%sphp.net/" target="_top">%s</a> at %s.</small>
+ </p>
+ </footer>
+ </div>
+diff --git a/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/index.html b/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/index.html
+index 2687444..77fe13e 100644
+--- a/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/index.html
++++ b/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/index.html
+@@ -108,7 +108,7 @@
+ <span class="success"><strong>High</strong>: 90% to 100%</span>
+ </p>
+ <p>
+- <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http://php.net/" target="_top">%s</a> at %s.</small>
++ <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http%sphp.net/" target="_top">%s</a> at %s.</small>
+ </p>
+ </footer>
+ </div>
+diff --git a/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/source_with_ignore.php.html b/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/source_with_ignore.php.html
+index 251b5c3..313d3be 100644
+--- a/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/source_with_ignore.php.html
++++ b/tests/_files/Report/HTML/CoverageForFileWithIgnoredLines/source_with_ignore.php.html
+@@ -244,7 +244,7 @@
+ <span class="warning"><strong>Dead Code</strong></span>
+ </p>
+ <p>
+- <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http://php.net/" target="_top">%s</a> at %s.</small>
++ <small>Generated by <a href="http://github.com/sebastianbergmann/php-code-coverage" target="_top">PHP_CodeCoverage %s</a> using <a href="http%sphp.net/" target="_top">%s</a> at %s.</small>
+ </p>
+ <a title="Back to the top" id="toplink" href="#"><span class="glyphicon glyphicon-arrow-up"></span></a>
+ </footer>