summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-06 08:47:35 +0100
committerRemi Collet <remi@remirepo.net>2018-02-06 08:47:35 +0100
commit0be8ee21bf2ade02ec5d829ea1a16fbb012c170d (patch)
treee26c312e0ef277f077819e7364ec74d9602a8e2f
parent15e3bc03ef9a045221e72f134abe45d231638431 (diff)
use range dependencies on F27+
-rw-r--r--php-phpunit-FinderFacade.spec31
1 files changed, 16 insertions, 15 deletions
diff --git a/php-phpunit-FinderFacade.spec b/php-phpunit-FinderFacade.spec
index f8da5e1..ccfa80a 100644
--- a/php-phpunit-FinderFacade.spec
+++ b/php-phpunit-FinderFacade.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-FinderFacade
#
-# Copyright (c) 2012-2017 Remi Collet
+# Copyright (c) 2012-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,7 +17,7 @@
Name: php-phpunit-FinderFacade
Version: 1.2.2
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Wrapper for Symfony Finder component
Group: Development/Libraries
@@ -30,28 +30,26 @@ BuildRequires: php(language) >= 5.3.3
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
BuildRequires: %{_bindir}/phpunit
-BuildRequires: php-composer(theseer/fdomdocument) < 2
-BuildRequires: php-composer(theseer/fdomdocument) >= 1.3
-%if 0%{?fedora} >= 26
-BuildRequires: php-composer(symfony/finder) < 5
+%if 0%{?fedora} >= 27
+BuildRequires: (php-composer(theseer/fdomdocument) >= 1.3 with php-composer(theseer/fdomdocument) < 2)
+BuildRequires: (php-composer(symfony/finder) >= 2.3 with php-composer(symfony/finder) < 5)
%else
-BuildRequires: php-composer(symfony/finder) < 4
+BuildRequires: php-theseer-fDOMDocument
+BuildRequires: php-symfony-finder
%endif
-BuildRequires: php-composer(symfony/finder) >= 2.3
%endif
# From composer.json "require": {
# "theseer/fdomdocument": "~1.3",
# "symfony/finder": "~2.3|~3.0|~4.0"
Requires: php(language) >= 5.3.3
-Requires: php-composer(theseer/fdomdocument) < 2
-Requires: php-composer(theseer/fdomdocument) >= 1.3
-%if 0%{?fedora} >= 26
-Requires: php-composer(symfony/finder) < 5
+%if 0%{?fedora} >= 27
+Requires: (php-composer(theseer/fdomdocument) >= 1.3 with php-composer(theseer/fdomdocument) < 2)
+Requires: (php-composer(symfony/finder) >= 2.3 with php-composer(symfony/finder) < 5)
%else
-Requires: php-composer(symfony/finder) < 4
+Requires: php-theseer-fDOMDocument
+Requires: php-symfony-finder
%endif
-Requires: php-composer(symfony/finder) >= 2.3
# From phpcompatinfo report for version 1.2.1
Requires: php-ctype
# For our autoloader
@@ -98,7 +96,7 @@ cp -pr src %{buildroot}%{php_home}/SebastianBergmann/FinderFacade
php -r 'require "%{buildroot}%{php_home}/SebastianBergmann/FinderFacade/autoload.php";'
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/SebastianBergmann/FinderFacade/autoload.php \
%{_bindir}/phpunit --verbose tests || ret=1
@@ -125,6 +123,9 @@ fi
%changelog
+* Tue Feb 6 2018 Remi Collet <remi@fedoraproject.org> - 1.2.2-2
+- use range dependencies on F27+
+
* Sun Nov 19 2017 Remi Collet <remi@remirepo.net> - 1.2.2-1
- Update to 1.2.2
- allow Symfony 4