summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-27 08:33:09 +0100
committerRemi Collet <remi@remirepo.net>2017-11-27 08:33:09 +0100
commitb7f95e4e0519f7135dd761be63318ca4737d6e49 (patch)
tree1ece849ef559145e53a016af29a8e484550a8bc3
parente09255cbc86727b2e3f764fc98ad69bb27e08e27 (diff)
v1.4.3
-rw-r--r--.gitignore8
-rw-r--r--php-phpunit-File-Iterator.spec14
2 files changed, 13 insertions, 9 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-phpunit-File-Iterator.spec b/php-phpunit-File-Iterator.spec
index a1635a8..19b4638 100644
--- a/php-phpunit-File-Iterator.spec
+++ b/php-phpunit-File-Iterator.spec
@@ -7,7 +7,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 3cc8f69b3028d0f96a9078e6295d86e9bf019be5
+%global gh_commit 8ebba84e5bd74fc5fdeb916b38749016c7232f93
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-file-iterator
@@ -18,7 +18,7 @@
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: php-phpunit-File-Iterator
-Version: 1.4.2
+Version: 1.4.3
Release: 1%{?dist}
Summary: FilterIterator implementation that filters files based on a list of suffixes
@@ -27,7 +27,6 @@ License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.3
BuildRequires: php-fedora-autoloader-devel
@@ -69,15 +68,10 @@ mv File/Iterator/Iterator.php File/Iterator.php
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}
cp -pr File %{buildroot}%{php_home}/File
-%clean
-rm -rf %{buildroot}
-
-
%post
if [ -x %{_bindir}/pear ]; then
%{_bindir}/pear uninstall --nodeps --ignore-errors --register-only \
@@ -86,7 +80,6 @@ fi
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc ChangeLog.md README.md composer.json
@@ -94,6 +87,9 @@ fi
%changelog
+* Mon Nov 27 2017 Remi Collet <remi@remirepo.net> - 1.4.3-1
+- Update to 1.4.3
+
* Sat Nov 26 2016 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
- update to 1.4.2 (no change)
- switch to fedora/autoloader