summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-04-03 15:33:18 +0200
committerRemi Collet <fedora@famillecollet.com>2015-04-03 15:33:18 +0200
commit0e1a887f8e1de385b89d7475f1792371aa043020 (patch)
tree4cc7c22e61dc934ffade2252fec11e09d84f7daf
parent51a68ad73abbfa187d2ef741946d7794551fbb70 (diff)
php-phpunit-File-Iterator: cleanups
-rw-r--r--php-phpunit-File-Iterator.spec7
1 files changed, 2 insertions, 5 deletions
diff --git a/php-phpunit-File-Iterator.spec b/php-phpunit-File-Iterator.spec
index 61e82c5..4db862e 100644
--- a/php-phpunit-File-Iterator.spec
+++ b/php-phpunit-File-Iterator.spec
@@ -53,24 +53,21 @@ FilterIterator implementation that filters files based on a list of suffixes.
%setup -q -n %{gh_project}-%{gh_commit}
# Restore PSR-0 tree
+# see https://github.com/sebastianbergmann/php-file-iterator/issues/26
mkdir -p File/Iterator/
mv src/* File/Iterator/
mv File/Iterator/Iterator.php File/Iterator.php
-
%build
%{_bindir}/phpab \
--output File/Iterator/Autoload.php \
--basedir File/Iterator \
File
-cat File/Iterator/Autoload.php
%install
rm -rf %{buildroot}
-# Restore PSR-0 tree
-# see https://github.com/sebastianbergmann/php-file-iterator/issues/26
mkdir -p %{buildroot}%{php_home}
cp -pr File %{buildroot}%{php_home}/File
@@ -91,7 +88,7 @@ fi
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc ChangeLog.md README.md composer.json
-%{php_home}/*
+%{php_home}/File
%changelog