summaryrefslogtreecommitdiffstats
path: root/php-phpunit-DbUnit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-DbUnit.spec')
-rw-r--r--php-phpunit-DbUnit.spec29
1 files changed, 9 insertions, 20 deletions
diff --git a/php-phpunit-DbUnit.spec b/php-phpunit-DbUnit.spec
index 38c9ebc..ed12be5 100644
--- a/php-phpunit-DbUnit.spec
+++ b/php-phpunit-DbUnit.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-DbUnit
#
-# Copyright (c) 2010-2017 Remi Collet
+# Copyright (c) 2010-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,16 +13,11 @@
%global php_home %{_datadir}/php
%global pear_name DbUnit
%global pear_channel pear.phpunit.de
-%if 0%{?rhel} == 5
-# libxml is too old for LIBXML_PARSEHUGE used in tests
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
-%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-%endif
+%global with_tests 0%{!?_without_tests:1}
Name: php-phpunit-DbUnit
Version: 2.0.3
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: DbUnit port for PHP/PHPUnit
Group: Development/Libraries
@@ -33,13 +28,12 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Autoloader full path
Patch0: %{gh_project}-2.0.0-autoload.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.4
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
BuildRequires: php-pdo
-BuildRequires: php-composer(phpunit/phpunit) >= 4
+BuildRequires: php-phpunit-PHPUnit
%endif
# From composer.json
@@ -51,10 +45,8 @@ BuildRequires: php-composer(phpunit/phpunit) >= 4
Requires: php(language) >= 5.4
Requires: php-pdo
Requires: php-simplexml
-Requires: php-composer(phpunit/phpunit) >= 4
-Requires: php-composer(phpunit/phpunit) < 6
-Requires: php-composer(symfony/yaml) >= 2.1
-Requires: php-composer(symfony/yaml) < 4
+Requires: php-phpunit-PHPUnit
+Requires: php-symfony-yaml
# From phpcompatinfo report for version 1.3.0
Requires: php-libxml
Requires: php-reflection
@@ -83,7 +75,6 @@ DbUnit port for PHP/PHPUnit.
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}
cp -pr src %{buildroot}%{php_home}/PHPUnit
@@ -104,10 +95,6 @@ install -D -p -m 755 dbunit %{buildroot}%{_bindir}/dbunit
%endif
-%clean
-rm -rf %{buildroot}
-
-
%post
if [ -x %{_bindir}/pear ]; then
%{_bindir}/pear uninstall --nodeps --ignore-errors --register-only \
@@ -116,7 +103,6 @@ fi
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc ChangeLog.md
@@ -127,6 +113,9 @@ fi
%changelog
+* Tue Feb 6 2018 Remi Collet <remi@fedoraproject.org> - 1.2.4-4
+- use package name for dependencies
+
* Sun Dec 4 2016 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
- update to 2.0.3
- switch to fedora/autoloader