summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phpunit-DbUnit.spec23
1 files changed, 14 insertions, 9 deletions
diff --git a/php-phpunit-DbUnit.spec b/php-phpunit-DbUnit.spec
index ed12be5..d7f59b7 100644
--- a/php-phpunit-DbUnit.spec
+++ b/php-phpunit-DbUnit.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-DbUnit
#
-# Copyright (c) 2010-2018 Remi Collet
+# Copyright (c) 2010-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,10 +17,9 @@
Name: php-phpunit-DbUnit
Version: 2.0.3
-Release: 4%{?dist}
+Release: 11%{?dist}
Summary: DbUnit port for PHP/PHPUnit
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
@@ -46,7 +45,7 @@ Requires: php(language) >= 5.4
Requires: php-pdo
Requires: php-simplexml
Requires: php-phpunit-PHPUnit
-Requires: php-symfony-yaml
+Requires: php-symfony4-yaml
# From phpcompatinfo report for version 1.3.0
Requires: php-libxml
Requires: php-reflection
@@ -87,11 +86,14 @@ install -D -p -m 755 dbunit %{buildroot}%{_bindir}/dbunit
%{_bindir}/phpab --template fedora --output tests/bs.php tests
: Run tests - set include_path to ensure PHPUnit autoloader use it
-%{_bindir}/php -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
-%{_bindir}/phpunit \
- --bootstrap tests/bs.php \
- --configuration ./build/phpunit.xml \
- --verbose
+for cmd in php php73 php74 php80; do
+ if which $cmd; then
+ $cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
+ %{_bindir}/phpunit \
+ --bootstrap tests/bs.php \
+ --configuration ./build/phpunit.xml
+ fi
+done
%endif
@@ -113,6 +115,9 @@ fi
%changelog
+* Thu Mar 25 2021 Remi Collet <remi@fedoraproject.org> - 1.2.4-11
+- switch to Symfony 4
+
* Tue Feb 6 2018 Remi Collet <remi@fedoraproject.org> - 1.2.4-4
- use package name for dependencies