summaryrefslogtreecommitdiffstats
path: root/php-phpunit-DbUnit.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-07 19:22:41 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-07 19:22:41 +0200
commitf637cdf200b20ddb8a406cc977d0b2fbebd1a5cb (patch)
tree6728c4c5c67d9c5d18c82165b430a8c49bb676ab /php-phpunit-DbUnit.spec
php-phpunit-DbUnit: import from rawhide
Diffstat (limited to 'php-phpunit-DbUnit.spec')
-rw-r--r--php-phpunit-DbUnit.spec120
1 files changed, 120 insertions, 0 deletions
diff --git a/php-phpunit-DbUnit.spec b/php-phpunit-DbUnit.spec
new file mode 100644
index 0000000..485cb73
--- /dev/null
+++ b/php-phpunit-DbUnit.spec
@@ -0,0 +1,120 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name DbUnit
+%global channel pear.phpunit.de
+
+Name: php-phpunit-DbUnit
+Version: 1.1.2
+Release: 2%{?dist}
+Summary: DbUnit port for PHP/PHPUnit
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/sebastianbergmann/dbunit
+Source0: http://pear.phpunit.de/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.9.4
+BuildRequires: php-channel(%{channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pdo >= 5.2.7
+Requires: php-pear(%{channel}/PHPUnit) >= 3.6.0
+Requires: php-pear(pear.symfony-project.com/YAML) >= 1.0.2
+
+Provides: php-pear(%{channel}/%{pear_name}) = %{version}
+
+
+%description
+DbUnit port for PHP/PHPUnit
+
+%prep
+%setup -q -c
+cd %{pear_name}-%{version}
+# package.xml is V2
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/PHPUnit/Extensions/Database
+%{_bindir}/dbunit
+
+
+%changelog
+* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Fri Jan 27 2012 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
+- Version 1.1.2 (stable) - API 1.1.0 (stable)
+
+* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Fri Nov 11 2011 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- Version 1.1.1 (stable) - API 1.1.0 (stable)
+
+* Tue Nov 01 2011 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- Version 1.1.0 (stable) - API 1.1.0 (stable)
+
+* Fri Aug 19 2011 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
+- Version 1.0.3 (stable) - API 1.0.0 (stable)
+
+* Fri Jun 10 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.2-1
+- Version 1.0.2 (stable) - API 1.0.0 (stable)
+- remove PEAR hack (only needed for EPEL)
+- raise PEAR dependency to 1.9.2
+
+* Tue May 3 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.1-2
+- rebuild for doc in /usr/share/doc/pear
+
+* Wed Feb 16 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.1-1
+- Version 1.0.1 (stable) - API 1.0.0 (stable)
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Fri Nov 05 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-2
+- lower PEAR dependency to allow el6 build
+- fix URL
+
+* Sun Sep 26 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-1
+- initial generated spec + clean
+
+