summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-03 15:23:19 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-03 15:23:19 +0100
commitb5239ca096f60443112e0aa7108d02a40b040e57 (patch)
treeda77a7fb9c4ac9586e768d6eff5a6b8e477c46fe
parent1de5c0332d8e4d5eead1636975781c09bc1ecaaa (diff)
php-phpunit-DbUnit: 2.0.2 (for PHPUnit 4 or 5)
-rw-r--r--dbunit-2.0.0-autoload.patch28
-rw-r--r--dbunit-autoload.patch15
-rw-r--r--php-phpunit-DbUnit-dev.spec218
-rw-r--r--php-phpunit-DbUnit.spec61
4 files changed, 65 insertions, 257 deletions
diff --git a/dbunit-2.0.0-autoload.patch b/dbunit-2.0.0-autoload.patch
new file mode 100644
index 0000000..00683ae
--- /dev/null
+++ b/dbunit-2.0.0-autoload.patch
@@ -0,0 +1,28 @@
+diff -up ./dbunit.rpm ./dbunit
+--- ./dbunit.rpm 2015-10-02 16:35:17.448763973 +0200
++++ ./dbunit 2015-10-02 16:36:38.991090874 +0200
+@@ -9,23 +9,7 @@
+ * file that was distributed with this source code.
+ */
+
+-foreach (array(__DIR__ . '/../../autoload.php', __DIR__ . '/../vendor/autoload.php', __DIR__ . '/vendor/autoload.php') as $file) {
+- if (file_exists($file)) {
+- define('DBUNIT_COMPOSER_INSTALL', $file);
+- break;
+- }
+-}
+-
+-unset($file);
+-
+-if (!defined('DBUNIT_COMPOSER_INSTALL')) {
+- fwrite(STDERR,
+- 'You need to set up the project dependencies using the following commands:' . PHP_EOL .
+- 'wget http://getcomposer.org/composer.phar' . PHP_EOL .
+- 'php composer.phar install' . PHP_EOL
+- );
+- die(1);
+-}
++define('DBUNIT_COMPOSER_INSTALL', '/usr/share/php/PHPUnit/Autoload.php');
+
+ require DBUNIT_COMPOSER_INSTALL;
+
diff --git a/dbunit-autoload.patch b/dbunit-autoload.patch
deleted file mode 100644
index bdc1f05..0000000
--- a/dbunit-autoload.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- dbunit.php.rpm 2015-08-07 08:17:06.899086351 +0200
-+++ dbunit.php 2015-08-07 08:17:37.693235622 +0200
-@@ -9,11 +9,7 @@
- * file that was distributed with this source code.
- */
-
--if (strpos('@php_bin@', '@php_bin') === 0) {
-- set_include_path(dirname(__FILE__) . PATH_SEPARATOR . get_include_path());
--}
--
--require_once 'PHPUnit/Autoload.php';
-+require_once '/usr/share/php/PHPUnit/Autoload.php';
-
- $command = new PHPUnit_Extensions_Database_UI_Command(
- new PHPUnit_Extensions_Database_UI_ModeFactory()
diff --git a/php-phpunit-DbUnit-dev.spec b/php-phpunit-DbUnit-dev.spec
deleted file mode 100644
index 893a37a..0000000
--- a/php-phpunit-DbUnit-dev.spec
+++ /dev/null
@@ -1,218 +0,0 @@
-# remirepo/fedora spec file for php-phpunit-DbUnit
-#
-# Copyright (c) 2010-2015 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%global gh_commit 12f7e91d83afe97c485261ec893997a141345caf
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner sebastianbergmann
-%global gh_project dbunit
-%global php_home %{_datadir}/php
-%global pear_name DbUnit
-%global pear_channel pear.phpunit.de
-%if 0%{?rhel} == 5
-# libxml is too old for LIBXML_PARSEHUGE used in tests
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
-%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-%endif
-
-Name: php-phpunit-DbUnit
-Version: 2.0.1
-Release: 1%{?dist}
-Summary: DbUnit port for PHP/PHPUnit
-
-Group: Development/Libraries
-License: BSD
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-
-# Autoloader full path
-Patch0: %{gh_project}-2.0.0-autoload.patch
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildArch: noarch
-BuildRequires: php(language) >= 5.6
-BuildRequires: %{_bindir}/phpab
-%if %{with_tests}
-BuildRequires: php-pdo
-# ignore min version, as tested with 4.8
-BuildRequires: php-composer(phpunit/phpunit) >= 4
-%endif
-
-# From composer.json
-# "php": ">=5.6",
-# "phpunit/phpunit": "~5",
-# "symfony/yaml": "~2.1|~3.0",
-# "ext-pdo": "*",
-# "ext-simplexml": "*"
-Requires: php(language) >= 5.6
-Requires: php-pdo
-Requires: php-simplexml
-Requires: php-composer(phpunit/phpunit) >= 5
-Requires: php-composer(phpunit/phpunit) < 6
-Requires: php-composer(symfony/yaml) >= 2.1
-Requires: php-composer(symfony/yaml) < 4
-# From phpcompatinfo report for version 1.3.0
-Requires: php-libxml
-Requires: php-reflection
-Requires: php-spl
-
-Provides: php-composer(phpunit/dbunit) = %{version}
-
-
-%description
-DbUnit port for PHP/PHPUnit.
-
-
-%prep
-%setup -q -n %{gh_project}-%{gh_commit}
-
-%patch0 -p1 -b .rpm
-
-
-%build
-: Generate library autoloader
-%{_bindir}/phpab \
- --output src/Extensions/Database/Autoload.php \
- src/Extensions/Database
-
-
-%install
-rm -rf %{buildroot}
-mkdir -p %{buildroot}%{php_home}
-cp -pr src %{buildroot}%{php_home}/PHPUnit
-
-install -D -p -m 755 dbunit %{buildroot}%{_bindir}/dbunit
-
-
-%if %{with_tests}
-%check
-: Generate tests autoloader
-%{_bindir}/phpab --output tests/bs.php tests
-
-: Run tests - set include_path to ensure PHPUnit autoloader use it
-%{_bindir}/php -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
-%{_bindir}/phpunit \
- --bootstrap tests/bs.php \
- --configuration ./build/phpunit.xml \
- --verbose
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%post
-if [ -x %{_bindir}/pear ]; then
- %{_bindir}/pear uninstall --nodeps --ignore-errors --register-only \
- %{pear_channel}/%{pear_name} >/dev/null || :
-fi
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license LICENSE
-%doc ChangeLog.md
-%doc samples
-%doc composer.json
-%{_bindir}/dbunit
-%{php_home}/PHPUnit/Extensions/Database
-
-
-%changelog
-* Fri Oct 2 2015 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
-- update to 2.0.1 (no change)
-
-* Fri Oct 2 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
-- update to 2.0.0
-- raise dependency on PHP version 5.6
-- raise dependency on PHPUnit version 5
-
-* Fri Aug 7 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
-- update to 1.4.1
-
-* Fri Jun 5 2015 Remi Collet <remi@fedoraproject.org> - 1.4.0-1
-- update to 1.4.0
-- raise dependency on PHPUnit 4.0
-- disable test suite on EL-5
-
-* Sun Mar 29 2015 Remi Collet <remi@fedoraproject.org> - 1.3.2-1
-- update to 1.3.2
-- switch all dependencies to composer
-
-* Sun Jun 08 2014 Remi Collet <remi@fedoraproject.org> - 1.3.1-4
-- fix FTBFS, add BR php-pdo
-- add composer provides
-- add composer.json as doc
-
-* Wed Apr 30 2014 Remi Collet <remi@fedoraproject.org> - 1.3.1-3
-- cleanup pear registry
-
-* Tue Apr 29 2014 Remi Collet <remi@fedoraproject.org> - 1.3.1-2
-- sources from github
-- run tests during build
-
-* Tue Apr 01 2014 Remi Collet <remi@fedoraproject.org> - 1.3.1-1
-- Update to 1.3.1
-
-* Fri Nov 01 2013 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
-- Update to 1.3.0
-- add requires: symfony2/Yaml
-
-* Tue Mar 05 2013 Remi Collet <remi@fedoraproject.org> - 1.2.3-1
-- Version 1.2.3 (stable) - API 1.2.0 (stable)
-
-* Thu Jan 10 2013 Remi Collet <remi@fedoraproject.org> - 1.2.2-1
-- Version 1.2.2 (stable) - API 1.2.0 (stable)
-
-* Sat Oct 6 2012 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
-- Version 1.2.1 (stable) - API 1.2.0 (stable)
-
-* Thu Sep 20 2012 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
-- Version 1.2.0 (stable) - API 1.2.0 (stable)
-- raise dependencies: php 5.3.3, PHPUnit 3.7.0,
- Yaml 2.1.0 (instead of YAML from symfony 1)
-
-* Fri Jan 27 2012 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
-- Version 1.1.2 (stable) - API 1.1.0 (stable)
-
-* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-2
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
-
-* Fri Nov 11 2011 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
-- Version 1.1.1 (stable) - API 1.1.0 (stable)
-
-* Tue Nov 01 2011 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
-- Version 1.1.0 (stable) - API 1.1.0 (stable)
-
-* Fri Aug 19 2011 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
-- Version 1.0.3 (stable) - API 1.0.0 (stable)
-
-* Fri Jun 10 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.2-1
-- Version 1.0.2 (stable) - API 1.0.0 (stable)
-- remove PEAR hack (only needed for EPEL)
-- raise PEAR dependency to 1.9.2
-
-* Tue May 3 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.1-2
-- rebuild for doc in /usr/share/doc/pear
-
-* Wed Feb 16 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.1-1
-- Version 1.0.1 (stable) - API 1.0.0 (stable)
-
-* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-3
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
-
-* Fri Nov 05 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-2
-- lower PEAR dependency to allow el6 build
-- fix URL
-
-* Sun Sep 26 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-1
-- initial generated spec + clean
-
-
diff --git a/php-phpunit-DbUnit.spec b/php-phpunit-DbUnit.spec
index 48d4a37..e2e2950 100644
--- a/php-phpunit-DbUnit.spec
+++ b/php-phpunit-DbUnit.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 9aaee6447663ff1b0cd50c23637e04af74c5e2ae
+%global gh_commit 390cefcb101e07e1d6400dbdfc3b90ecf2c1279f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project dbunit
@@ -21,7 +21,7 @@
%endif
Name: php-phpunit-DbUnit
-Version: 1.4.1
+Version: 2.0.2
Release: 1%{?dist}
Summary: DbUnit port for PHP/PHPUnit
@@ -31,23 +31,24 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
# Autoloader full path
-Patch0: %{gh_project}-autoload.patch
+Patch0: %{gh_project}-2.0.0-autoload.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-BuildRequires: php(language) >= 5.3.3
+BuildRequires: php(language) >= 5.4
+BuildRequires: %{_bindir}/phpab
%if %{with_tests}
BuildRequires: php-pdo
-BuildRequires: php-pear-PHPUnit >= 4.0
+BuildRequires: php-composer(phpunit/phpunit) >= 4
%endif
# From composer.json
-# "php": ">=5.3.3",
+# "php": ">=5.4",
# "phpunit/phpunit": "~4|~5",
# "symfony/yaml": "~2.1|~3.0",
# "ext-pdo": "*",
# "ext-simplexml": "*"
-Requires: php(language) >= 5.3.3
+Requires: php(language) >= 5.4
Requires: php-pdo
Requires: php-simplexml
Requires: php-composer(phpunit/phpunit) >= 4
@@ -69,36 +70,35 @@ DbUnit port for PHP/PHPUnit.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-rm PHPUnit/Extensions/Database/Autoload.php.in
-
-%patch0 -p0 -b .rpm
+%patch0 -p1 -b .rpm
%build
-# Empty build section, most likely nothing required.
-
-# If upstream drop Autoload.php, command to generate it.
-# Also remember to fix the command to use it.
-
-#phpab \
-# --output PHPUnit/Extensions/Database/Autoload.php \
-# --template PHPUnit/Extensions/Database/Autoload.php.in \
-# PHPUnit
+: Generate library autoloader
+%{_bindir}/phpab \
+ --output src/Extensions/Database/Autoload.php \
+ src/Extensions/Database
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}
-cp -pr PHPUnit %{buildroot}%{php_home}/PHPUnit
+cp -pr src %{buildroot}%{php_home}/PHPUnit
-install -D -p -m 755 dbunit.php %{buildroot}%{_bindir}/dbunit
+install -D -p -m 755 dbunit %{buildroot}%{_bindir}/dbunit
%if %{with_tests}
%check
+: Generate tests autoloader
+%{_bindir}/phpab --output tests/bs.php tests
+
: Run tests - set include_path to ensure PHPUnit autoloader use it
%{_bindir}/php -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
-%{_bindir}/phpunit --verbose
+%{_bindir}/phpunit \
+ --bootstrap tests/bs.php \
+ --configuration ./build/phpunit.xml \
+ --verbose
%endif
@@ -117,14 +117,27 @@ fi
%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
-%doc ChangeLog.markdown
-%doc Samples
+%doc ChangeLog.md
+%doc samples
%doc composer.json
%{_bindir}/dbunit
%{php_home}/PHPUnit/Extensions/Database
%changelog
+* Tue Nov 3 2015 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- update to 2.0.2 (no change)
+- lower dependency on PHP version 5.4
+- lower dependency on PHPUnit version 4
+
+* Fri Oct 2 2015 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- update to 2.0.1 (no change)
+
+* Fri Oct 2 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0
+- raise dependency on PHP version 5.6
+- raise dependency on PHPUnit version 5
+
* Fri Aug 7 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
- update to 1.4.1