summaryrefslogtreecommitdiffstats
path: root/php-phpstan-phpdoc-parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpstan-phpdoc-parser.spec')
-rw-r--r--php-phpstan-phpdoc-parser.spec122
1 files changed, 122 insertions, 0 deletions
diff --git a/php-phpstan-phpdoc-parser.spec b/php-phpstan-phpdoc-parser.spec
new file mode 100644
index 0000000..3c429f1
--- /dev/null
+++ b/php-phpstan-phpdoc-parser.spec
@@ -0,0 +1,122 @@
+# remirepo/Fedora spec file for php-phpstan-phpdoc-parser
+#
+# Copyright (c) 2023 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%bcond_without tests
+
+%global gh_commit e27e92d939e2e3636f0a1f0afaba59692c0bf571
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner phpstan
+%global gh_project phpdoc-parser
+%global php_home %{_datadir}/php
+%global namespace PHPStan
+%global library PhpDocParser
+%global major %nil
+
+Name: php-%{gh_owner}-%{gh_project}%{major}
+Version: 1.16.1
+Release: 1%{?dist}
+Summary: PHPDoc parser with support for nullable, intersection and generic types
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snapshot to retrieve test suite
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with tests}
+BuildRequires: php(language) >= 7.2
+BuildRequires: php-json
+BuildRequires: php-pcre
+# From composer, "require-dev": {
+# "php-parallel-lint/php-parallel-lint": "^1.2",
+# "phpstan/extension-installer": "^1.0",
+# "phpstan/phpstan": "^1.5",
+# "phpstan/phpstan-phpunit": "^1.1",
+# "phpstan/phpstan-strict-rules": "^1.0",
+# "phpunit/phpunit": "^9.5",
+# "symfony/process": "^5.2"
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^7.2 || ^8.0"
+Requires: php(language) >= 7.2
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.4.2
+Requires: php-json
+Requires: php-pcre
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Next generation phpDoc parser with support for intersection types and generics.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+phpab --template fedora --output src/autoload.php src
+
+
+%install
+: library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}%{major}
+
+
+%check
+%if %{with tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.php';
+EOF
+
+: ignore tests using symfony/process
+rm tests/PHPStan/Parser/FuzzyTest.php
+
+: upstream test suite
+ret=0
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} \
+ -d memory_limit=1G \
+ --no-coverage \
+ --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/%{namespace}
+ %{php_home}/%{namespace}/%{library}%{major}
+
+
+%changelog
+* Mon Mar 20 2023 Remi Collet <remi@remirepo.net> - 1.16.1-1
+- initial package