summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json12
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-phpstan-phpdoc-parser.spec49
3 files changed, 40 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index f1c648e..8047c49 100644
--- a/composer.json
+++ b/composer.json
@@ -3,17 +3,17 @@
"description": "PHPDoc parser with support for nullable, intersection and generic types",
"license": "MIT",
"require": {
- "php": "^7.2 || ^8.0"
+ "php": "^7.4 || ^8.0"
},
"require-dev": {
"doctrine/annotations": "^2.0",
- "nikic/php-parser": "^4.15",
+ "nikic/php-parser": "^5.3.0",
"php-parallel-lint/php-parallel-lint": "^1.2",
"phpstan/extension-installer": "^1.0",
- "phpstan/phpstan": "^1.5",
- "phpstan/phpstan-phpunit": "^1.1",
- "phpstan/phpstan-strict-rules": "^1.0",
- "phpunit/phpunit": "^9.5",
+ "phpstan/phpstan": "^2.0",
+ "phpstan/phpstan-phpunit": "^2.0",
+ "phpstan/phpstan-strict-rules": "^2.0",
+ "phpunit/phpunit": "^9.6",
"symfony/process": "^5.2"
},
"config": {
diff --git a/makesrc.sh b/makesrc.sh
index 65c4fd8..a68df44 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -20,6 +20,8 @@ else
pushd $PROJECT-$COMMIT
git checkout $COMMIT || exit 1
cp composer.json ../composer.json
+ rm build-abnfgen.sh
+ rm tests/abnfgen-0.20.tar.gz
popd
echo "Archiving..."
diff --git a/php-phpstan-phpdoc-parser.spec b/php-phpstan-phpdoc-parser.spec
index f27ab85..9e89962 100644
--- a/php-phpstan-phpdoc-parser.spec
+++ b/php-phpstan-phpdoc-parser.spec
@@ -1,15 +1,15 @@
# remirepo/Fedora spec file for php-phpstan-phpdoc-parser
#
-# Copyright (c) 2023-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2024-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
%bcond_without tests
-%global gh_commit 6ca22b154efdd9e3c68c56f5d94670920a1c19a4
+%global gh_commit 72e51f7c32c5aef7c8b462195b8c599b11199893
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpstan
%global gh_project phpdoc-parser
@@ -19,42 +19,42 @@
%global major %nil
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 1.32.0
+Version: 2.0.1
Release: 1%{?dist}
Summary: PHPDoc parser with support for nullable, intersection and generic types
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
# git snapshot to retrieve test suite
-Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.4
BuildRequires: php-json
BuildRequires: php-pcre
# From composer, "require-dev": {
# "doctrine/annotations": "^2.0",
-# "nikic/php-parser": "^4.15",
+# "nikic/php-parser": "^5.3.0",
# "php-parallel-lint/php-parallel-lint": "^1.2",
# "phpstan/extension-installer": "^1.0",
-# "phpstan/phpstan": "^1.5",
-# "phpstan/phpstan-phpunit": "^1.1",
-# "phpstan/phpstan-strict-rules": "^1.0",
-# "phpunit/phpunit": "^9.5",
+# "phpstan/phpstan": "^2.0",
+# "phpstan/phpstan-phpunit": "^2.0",
+# "phpstan/phpstan-strict-rules": "^2.0",
+# "phpunit/phpunit": "^9.6",
# "symfony/process": "^5.2"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5
+BuildRequires: phpunit9 >= 9.6
%endif
-BuildRequires: (php-composer(nikic/php-parser) >= 4.15 with php-composer(nikic/php-parser) < 5)
+BuildRequires: (php-composer(nikic/php-parser) >= 5.3 with php-composer(nikic/php-parser) < 6)
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.2 || ^8.0"
-Requires: php(language) >= 7.2
+# "php": "^7.4 || ^8.0"
+Requires: php(language) >= 7.4
# Autoloader
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 2.4.2
@@ -88,7 +88,7 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
// to avoid v5 from PHPUnit
-require_once '%{php_home}/PhpParser4/autoload.php';
+require_once '%{php_home}/PhpParser5/autoload.php';
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}\\%{library}\\', dirname(__DIR__) . '/tests/%{namespace}');
EOF
@@ -127,6 +127,21 @@ exit $ret
%changelog
+* Thu Feb 13 2025 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- update to 2.0.1
+
+* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0
+- raise dependency on PHP 7.4
+- raise dependency on nikic/php-parser 5.3
+
+* Tue Dec 17 2024 Remi Collet <remi@remirepo.net> - 1.33.0-2
+- drop abnfgen from archive
+- re-license spec file to CECILL-2.1
+
+* Mon Oct 14 2024 Remi Collet <remi@remirepo.net> - 1.33.0-1
+- update to 1.33.0
+
* Thu Sep 26 2024 Remi Collet <remi@remirepo.net> - 1.32.0-1
- update to 1.32.0