summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-02 07:44:25 +0200
committerRemi Collet <remi@php.net>2023-06-02 07:44:25 +0200
commitec4c02c3a0929d5e4aa59569c40040321293e578 (patch)
tree5ed896b618dd445a3d96572d739a6433bde75df3
parent6fd31dc6cc8eddfed99f92b4c72ebf45b329de84 (diff)
update to 1.22.0
-rw-r--r--composer.json1
-rw-r--r--php-phpstan-phpdoc-parser.spec10
2 files changed, 9 insertions, 2 deletions
diff --git a/composer.json b/composer.json
index 30b879b..f1c648e 100644
--- a/composer.json
+++ b/composer.json
@@ -6,6 +6,7 @@
"php": "^7.2 || ^8.0"
},
"require-dev": {
+ "doctrine/annotations": "^2.0",
"nikic/php-parser": "^4.15",
"php-parallel-lint/php-parallel-lint": "^1.2",
"phpstan/extension-installer": "^1.0",
diff --git a/php-phpstan-phpdoc-parser.spec b/php-phpstan-phpdoc-parser.spec
index 4f112b1..bad1abb 100644
--- a/php-phpstan-phpdoc-parser.spec
+++ b/php-phpstan-phpdoc-parser.spec
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit b0c366dd2cea79407d635839d25423ba07c55dd6
+%global gh_commit ec58baf7b3c7f1c81b3b00617c953249fb8cf30c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpstan
%global gh_project phpdoc-parser
@@ -19,7 +19,7 @@
%global major %nil
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 1.21.3
+Version: 1.22.0
Release: 1%{?dist}
Summary: PHPDoc parser with support for nullable, intersection and generic types
@@ -36,6 +36,7 @@ BuildRequires: php(language) >= 7.2
BuildRequires: php-json
BuildRequires: php-pcre
# From composer, "require-dev": {
+# "doctrine/annotations": "^2.0",
# "nikic/php-parser": "^4.15",
# "php-parallel-lint/php-parallel-lint": "^1.2",
# "phpstan/extension-installer": "^1.0",
@@ -94,6 +95,7 @@ rm tests/PHPStan/Parser/FuzzyTest.php
: upstream test suite
# use auto_prepend_file to ensure we use new version (not old one pulled by PHPUnit)
+# ignore test using doctrine/annotations
ret=0
for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
@@ -101,6 +103,7 @@ for cmdarg in "php %{phpunit}" php80 php81 php82; do
$1 -d auto_prepend_file=%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.php \
${2:-%{_bindir}/phpunit9} \
-d memory_limit=1G \
+ --filter '^((?!(testDoctrine)).)*$' \
--no-coverage \
--verbose || ret=1
fi
@@ -122,6 +125,9 @@ exit $ret
%changelog
+* Fri Jun 2 2023 Remi Collet <remi@remirepo.net> - 1.22.0-1
+- update to 1.22.0
+
* Tue May 30 2023 Remi Collet <remi@remirepo.net> - 1.21.3-1
- update to 1.21.3