summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phpspec.spec10
1 files changed, 7 insertions, 3 deletions
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 50ab37a..8f2dfd5 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit eae06d6b409fc1479e2f12d0a9ab1a88e2fda94c
+%global gh_commit 6c565f96cac52682684b0c02a180722ceead2c6c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
@@ -19,7 +19,7 @@
%global symfony_max 4
Name: php-phpspec
-Version: 4.0.2
+Version: 4.0.3
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -155,7 +155,7 @@ rm spec/PhpSpec/NamespaceProvider/ComposerPsrNamespaceProviderSpec.php
for cmd in php php70 php71 php72; do
if which $cmd; then
- $cmd -d include_path=.:%{buildroot}%{_datadir}/php \
+ $cmd -d memory_limit=1G -d include_path=.:%{buildroot}%{_datadir}/php \
bin/phpspec \
run --format pretty --verbose --no-ansi
@@ -176,6 +176,10 @@ done
%changelog
+* Sun Aug 27 2017 Remi Collet <remi@remirepo.net> - 4.0.3-1
+- Update to 4.0.3
+- raise memory_limit for test suite
+
* Mon Aug 7 2017 Remi Collet <remi@remirepo.net> - 4.0.2-1
- Update to 4.0.2
- raise dependency on symfony 3.2